Bug 1854704 - [v2v][VMware to CNV VM import] vddk-init-image not renewed for an existing VM import
Summary: [v2v][VMware to CNV VM import] vddk-init-image not renewed for an existing VM...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Tomas Jelinek
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-08 04:38 UTC by Ilanit Stein
Modified: 2020-10-27 16:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:12:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:13:15 UTC

Description Ilanit Stein 2020-07-08 04:38:16 UTC
Description of problem:
VM import a RHEL-8 VM on a newly deployed CNV environment, where vddk-init-image was not added yet to the v2v-vmware ConfigMap.

After ~12h a working vddk-init-image was added properly to the v2v-vmware ConfigMap.

VM event showed that It tried to read this image bug failed.


Then I ran VM import for exact same VM, without changing the vddk-init-image in the configMap, and the VM import started - That is the vddk-init-image was read/used just fine.

The first VM import stayed in "Import pending" state (was checked 30 minutes later).  

VM last Events:

PodPkubevirt-v2v-conversion-rhel8-vm-frjsx
NamespaceNSdefault
3 minutes ago
Generated from kubelet on istein1-g9v6r-worker-6t72l
3429 times in the last 12 hours
Error: InvalidImageName
PodPkubevirt-v2v-conversion-rhel8-vm-frjsx
NamespaceNSdefault
8 minutes ago
Generated from kubelet on istein1-g9v6r-worker-6t72l
3406 times in the last 12 hours
Failed to apply default image tag "vddk-init-image is missing in the v2v-vmware ConfigMap": couldn't parse image reference "vddk-init-image is missing in the v2v-vmware ConfigMap": invalid reference format: repository name must be lowercase

Version-Release number of selected component (if applicable):
CNV-2.4 from July 07

Comment 10 Ilanit Stein 2020-08-13 08:50:03 UTC
Changing the component to v2v as this is a backend bug.

Comment 12 Tomas Jelinek 2020-09-21 08:42:01 UTC
This and many other cases have been added fixed in https://bugzilla.redhat.com/show_bug.cgi?id=1874055
Moving this BZ to ON_QA for independent verification.

Comment 13 Tomas Jelinek 2020-09-23 11:51:21 UTC
no doc update - will be described in the bz from comment 12

Comment 15 Ilanit Stein 2020-10-12 15:07:32 UTC
Tested on OCP-4.6/CNV-2.5(from Oct 09 2020) - VM import from VMware cannot be performed in case vddk-init is not available. 
In the VM import wizard there is a warning on missing vddk-init image, however it is possible to run "Import", which immeditly fails with this error in the "result" page:

Error creating virtual machine.
Error "Required value" for field "spec.initContainers[0].image".

Pod kubevirt-v2v-conversion-rhel8template- failed to create

Based on the above this bug cannot be tested/verified and seem to be not relvant anymore as no vddk-init image blocks VM import from getting started.

Comment 17 errata-xmlrpc 2020-10-27 16:12:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.