Bug 1854751 - [gcp]"interruptible-instance" label was not propagated onto nodes
Summary: [gcp]"interruptible-instance" label was not propagated onto nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Alexander Demicev
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-08 07:50 UTC by sunzhaohua
Modified: 2020-10-27 16:13 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:12:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:13:15 UTC

Description sunzhaohua 2020-07-08 07:50:03 UTC
Description of problem:
"interruptible-instance" label was not propagated onto nodes

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-07-233934

How reproducible:
always

Steps to Reproduce:
1. Create a spot instance with "preemptible: true"
2. Check machine labels
3. Check node labels

Actual results:
"interruptible-instance" label was not propagated onto nodes.
$ oc get machine zhsungcp78-vjlq4-worker-f-v8m99 --show-labels | grep "interruptible"
zhsungcp78-vjlq4-worker-f-v8m99   Running   n1-standard-4   us-central1   us-central1-f   35m   machine.openshift.io/cluster-api-cluster=zhsungcp78-vjlq4,machine.openshift.io/cluster-api-machine-role=worker,machine.openshift.io/cluster-api-machine-type=worker,machine.openshift.io/cluster-api-machineset=zhsungcp78-vjlq4-worker-f,machine.openshift.io/instance-type=n1-standard-4,machine.openshift.io/interruptible-instance=,machine.openshift.io/region=us-central1,machine.openshift.io/zone=us-central1-f

$ oc get node zhsungcp78-vjlq4-worker-f-v8m99.c.openshift-qe.internal --show-labels | grep "interruptible"

$ oc get ds
NAME                              DESIRED   CURRENT   READY   UP-TO-DATE   AVAILABLE   NODE SELECTOR                                  AGE
machine-api-termination-handler   0         0         0       0            0           machine.openshift.io/interruptible-instance=   33m

Expected results:
"interruptible-instance" label was propagated onto Nodes

Additional info:

Comment 3 sunzhaohua 2020-07-14 03:34:37 UTC
Verified
Clusterversion: 4.6.0-0.nightly-2020-07-13-051854

"interruptible-instance" label was propagated onto Nodes

$ oc get node zhsun713gcp-l87m9-worker-f-p4cv5.c.openshift-qe.internal --show-labels |  grep "interruptible"
zhsun713gcp-l87m9-worker-f-p4cv5.c.openshift-qe.internal   Ready    worker   55m   v1.18.3+b9ac23f   beta.kubernetes.io/arch=amd64,beta.kubernetes.io/instance-type=n1-standard-4,beta.kubernetes.io/os=linux,failure-domain.beta.kubernetes.io/region=us-central1,failure-domain.beta.kubernetes.io/zone=us-central1-f,kubernetes.io/arch=amd64,kubernetes.io/hostname=zhsun713gcp-l87m9-worker-f-p4cv5.c.openshift-qe.internal,kubernetes.io/os=linux,machine.openshift.io/interruptible-instance=,node-role.kubernetes.io/worker=,node.kubernetes.io/instance-type=n1-standard-4,node.openshift.io/os_id=rhcos,topology.kubernetes.io/region=us-central1,topology.kubernetes.io/zone=us-central1-f

Comment 5 errata-xmlrpc 2020-10-27 16:12:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.