Bug 185477 - ldif2db allows entries without a parent to be imported
ldif2db allows entries without a parent to be imported
Status: CLOSED NEXTRELEASE
Product: Red Hat Directory Server
Classification: Red Hat
Component: Command Line Utilities (Show other bugs)
7.1
All Linux
medium Severity medium
: DS8.0
: ---
Assigned To: Nathan Kinder
Orla Hegarty
:
Depends On:
Blocks: 159328 182367
  Show dependency treegraph
 
Reported: 2006-03-14 19:21 EST by Orla Hegarty
Modified: 2008-08-11 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 16:11:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CVS Diffs (847 bytes, patch)
2006-03-14 19:25 EST, Nathan Kinder
no flags Details | Diff
cvs commit idl_new.c (HEAD and Directory71RtmBranch) (1.35 KB, text/plain)
2006-03-14 19:51 EST, Noriko Hosoi
no flags Details
cvs diff ldif2ldbm.c and the commit message (1.70 KB, text/plain)
2006-03-15 21:59 EST, Noriko Hosoi
no flags Details

  None (edit)
Comment 1 Nathan Kinder 2006-03-14 19:25:56 EST
Created attachment 126135 [details]
CVS Diffs

The problem is that the new IDL code is not exposing the DB_NOTFOUND error when
the index key is not found.  Import checks if the result was DB_NOTFOUND when
checking for the parent entry's entrydn index.	This works fine with the old
IDL code.
Comment 2 Noriko Hosoi 2006-03-14 19:51:40 EST
Created attachment 126136 [details]
cvs commit idl_new.c (HEAD and Directory71RtmBranch)

I've checked in the fix (idl_new.c) into CVS HEAD as well as
Directory71RtmBranch on behalf of Nathan.

Reviewed by Rich and Noriko.
Comment 3 Orla Hegarty 2006-03-14 20:19:46 EST
*DOCS*
In previous 7.X versions of Red Hat Directory Server, importing a malformed
parent entry and some child entries resulted in the child entries being
successfully added without a parent. This has been fixed.
Comment 4 Noriko Hosoi 2006-03-15 21:59:18 EST
Created attachment 126192 [details]
cvs diff ldif2ldbm.c and the commit message

File:
ldif2ldbm.c

Change:
if returned idl is NULL, changed add_op_attrs to always set
IMPORT_ADD_OP_ATTRS_NO_PARENT in non-error case (err == 0 or err ==
DB_NOTFOUND).

Reviewed by Rich (Thank you!!!)
Comment 5 Orla Hegarty 2006-03-16 16:49:57 EST
New testcases added to import test plan to verify this bug. Verified fixed
against all supported platforms for DS 7.1 SP 2 
Comment 7 Orla Hegarty 2006-05-26 13:49:07 EDT
Somehow the errata system did not automatically close these bugs even though DS
SP 2 is shipped and available live on RHN
Comment 8 Orla Hegarty 2006-05-26 13:52:27 EDT
trying to manually close
Comment 9 Orla Hegarty 2006-05-26 16:11:50 EDT
trying again
Comment 10 Chandrasekar Kannan 2007-07-25 15:19:30 EDT
DS7.2 is not a valid milestone anymore. Anything thats set to DS7.2 should be
set to DS8.0. Will make further changes per bug council on 07/24/2007, after this.
Comment 11 Chandrasekar Kannan 2008-08-11 19:45:08 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.