Bug 185479 - bump lftp to current version
bump lftp to current version
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lftp (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Skala
: FutureFeature, Rebase
Depends On:
  Show dependency treegraph
Reported: 2006-03-14 19:47 EST by nathan r. hruby
Modified: 2014-11-09 17:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-02-23 04:44:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description nathan r. hruby 2006-03-14 19:47:42 EST
Description of problem:

lftp in RHEL4 is version 3.0.6, released on 2004-06-12.  Current version is
3.4.0 which was released on 2005-12-31.  This version has *many* bugfixes and
includes DAV support.  Please consider upgrading lftp for the next Update spin.
 Also note this will require perl-String-CRC32 to be added for dependancies.



Version-Release number of selected component (if applicable):
Comment 1 Jason Vas Dias 2006-03-15 11:41:36 EST
We are not allowed to upgrade any software in RHEL to a version number change - 
all fixes must be backported for specific bugs. If you'd like to raise a
bugzilla for each lftp bug that you want fixed, I can backport changes from
3.4.x to 3.0.6 to fix each bug.
Alternatively, you could simply install the lftp-3.4.2-1.EL4 and
perl-String-CRC32-1.3-1.EL4 RPMs from :
There are binary i386 RPMs there, and the SRPM, so if you need lftp for a 
different architecture, then :
  $ rpmbuild --rebuild lftp-3.4.2-1.EL4.src.rpm
  $ rpmbuild --rebuild perl-String-CRC32-1.3-1.EL4.src.rpm
These RPMs will not be "officially supported" by Red Hat, but I as the lftp
and perl-String-CRC32 package maintainer do undertake to support them.
Comment 2 Jason Vas Dias 2006-03-17 18:09:49 EST
Well, I'll hand this over to PM for consideration - can we update lftp to 3.4.x
in RHEL-4 ? I can't see any negative impact.
Comment 8 David Tonhofer 2007-10-30 09:23:11 EDT
lftp still at lftp-3.0.6-3 with no patches (i.e. the source has no patches as I
can see). 
Comment 14 Jiri Skala 2008-10-14 02:11:54 EDT
Re-based to current RHEL5 version 3.7.3.
Comment 18 Jiri Skala 2010-02-23 04:44:08 EST
There is no another issue. Don't recommend bump.

Note You need to log in before you can comment on or make changes to this bug.