Bug 185490 - Unicode LRO defect
Unicode LRO defect
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 01:16 EST by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-30 14:40:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snippet (1.37 KB, text/x-csrc)
2006-03-15 02:03 EST, Jong Bae KO
no flags Details
Bad shaping (5.96 KB, image/png)
2006-03-15 02:05 EST, Jong Bae KO
no flags Details
Good shaping (11.41 KB, image/png)
2006-03-15 02:06 EST, Jong Bae KO
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 150883 None None None Never

  None (edit)
Description Jong Bae KO 2006-03-15 01:16:37 EST
Description of problem:
"When LRO is used PangoLayout shaping fails.
Compile and run the snippet, notice the shaping is wrong.

The unicode sequence is: 
\u202d\u0637\u0627\u0644\u0628\u0020\u0633\u0644\u0627\u0645\u0020\u0645\u062d\u0645\u062f
Where \u202d == LRO" 
http://bugzilla.gnome.org/show_bug.cgi?id=150883

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jong Bae KO 2006-03-15 02:03:45 EST
Created attachment 126144 [details]
snippet
Comment 2 Jong Bae KO 2006-03-15 02:05:08 EST
Created attachment 126145 [details]
Bad shaping
Comment 3 Jong Bae KO 2006-03-15 02:06:06 EST
Created attachment 126146 [details]
Good shaping
Comment 4 Matthias Clasen 2006-06-20 01:09:44 EDT
Reassigning pango bugs to Behdad.
Comment 5 Akira TAGOH 2006-11-01 08:39:00 EST
Jong, does this still happen on fc6 say?
Comment 6 Jong Bae KO 2006-11-02 01:18:15 EST
Hi, Tagoh

I am trying to test it, but how can i test it?
I couldn't figure out yet, because I just reported it :(
.
Comment 7 Behdad Esfahbod 2006-11-02 18:46:44 EST
It still happens, yes.   This needs some time to fix it properly, but it's
rather low priority on my scale.
Comment 8 Liang Zhang 2007-09-27 23:25:04 EDT
This bug in the upstream bugzilla is:
http://bugzilla.gnome.org/show_bug.cgi?id=150883

And this bug in the upstream bugzilla has already been fixed.
So this bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.