Bug 185497 - Need restorecon /dev/pts
Need restorecon /dev/pts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 185436 204330
  Show dependency treegraph
 
Reported: 2006-03-15 03:59 EST by Russell Coker
Modified: 2014-03-16 22:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8.31.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 11:07:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2006-03-15 03:59:59 EST
Description of problem:  
Need to have "restorecon /dev/pts" after "mount -n /dev/pts >/dev/null 2>&1"  
in /etc/rc.d/rc.sysinit so that the correct context is assigned on MLS 
systems.  This will have no affect on non-MLS systems (apart from a small 
fraction of a second taken for the operation) but is required for correct MLS 
functionality. 
  
Additional info:  
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=185436 
 
The root cause of this is a deficiency in the kernel code (see above 
bugzilla).  Fixing the kernel code in question is not going to be easy and 
will not happen in the near future.  So we need to have a work-around in init 
scripts.
Comment 1 Bill Nottingham 2006-03-15 11:07:19 EST
Already done in 8.31.1-1.

Note You need to log in before you can comment on or make changes to this bug.