Bug 18551 - 3COM 3C905C driver unavailable
3COM 3C905C driver unavailable
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 13:05 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-01 15:56:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-06 13:05:22 EDT
This NIC is listed a fully supported for 7.0 and it is supported under 6.2,
but the install process does not find the card.  When trying to manually
set the interface, the drive for 3C90x is not listed..
Comment 1 Doug Ledford 2000-10-06 13:19:13 EDT
The 3c905c is fully supported by the kernel.  If that particular driver isn't on
the install media then that would be an install problem, not a kernel problem. 
I'm changing the component to reflect that.
Comment 2 Doug Ledford 2000-10-06 13:21:42 EDT
Assigning to msw
Comment 3 Matt Wilson 2000-10-06 14:37:05 EDT
both 3c90x and 3c59x are on the bootnet.img - what is the pci id of this card
and which driver does it use?
Comment 4 Need Real Name 2000-10-06 15:25:11 EDT
I not sure I understand the question but the information from /proc/pci is.  

Bus  2, device   9, function  0:
    Ethernet controller: 3Com Unknown device (rev 48).
      Vendor id=10b7. Device id=9200.
      Medium devsel.  IRQ 18.  Master Capable.  Latency=64.  Min Gnt=10.Max
Lat=10.
      I/O at 0x1000 [0x1001].
      Non-prefetchable 32 bit memory at 0x40100000 [0x40100000].

The actual card is a 3C905C-TX-M.

Again to restate what happens.
Under 6.2 the install process || the plug and play process sees the NIC card.
Under 7.0 the card is not detected, and the device driver is not listed when
trying to manually set the device through linuxconf.
Comment 5 Need Real Name 2000-10-12 15:44:45 EDT
I have seen similar issues with a 3COM 3C900B-TPO card.  RH6.2 saw it during 
PnP install but not RH7.  Please contact me if you would like more detailed 
info.  Observations:  3COM's web provides you with the source for 3C90X driver 
and I have note been successfull at compiling it and "insmod"ing it.  However 
there is a file called 3C90X.O on my RH7 system that must be from the install.  
Adding a specific alias didn't help either (in MODULES.CONF file).  This issue 
may be related to the cards using virutal resources if ever used in a Win9X 
system.  At this time I am unable to use any DOS diagnostics from 3COM or get 
the cad to be seen by MS-DOS LAN Manager.  The Base I/O address (as reported by 
WIN98 SE) is very high and would help explain why DOS utils can't see it.  
Unfortunately those utils are needed to change the EPROM settings on the NIC.  
Again, email me if additional info. and/research will aid in solving this issue.
Comment 6 Ignacio Vazquez-Abrams 2000-10-19 18:14:09 EDT
Stay away from the 3c90x.o module. It is EVIL. I have seen machines lock up a
couple of seconds after network startup if this module is used. Use 3c59x.o for
3C905x's instead. And for pete's sake, stay the hell away from 3C900's. they are
evil even under a so-called "supported" (i.e. Win32) operating system.
Comment 7 Need Real Name 2000-10-19 22:37:10 EDT
As far as my issue is concerned I have solved my issue with the 3C900B NIC from
3COM.  The problem was not saying "NO" in the BIOS settings for whether or not I
had a PnP OS.  I selected "NO" for that option and my NIC and sound card were
detected at bootup with no problem.  Thanks to anyone who considered a solution
to my previous post.

Comment 8 Need Real Name 2000-10-21 00:12:36 EDT
Additional note:  The driver my NIC is using automatically in RH7 is 3C905 
driver that is "unavailable".  Just disable the PnP OS option in system setup.
Comment 9 Need Real Name 2000-11-01 16:53:28 EST
I can't believe this is an acceptable solution to solving a discrepancy between
the 6.2 and 7.0 installer.  The fact is the installer is a critical first step
in impressing the user and if you are saying that 7.0 not seeing the NIC is a
step up from 6.2, RH is going to continue fail the Linux community.  Moving on
to Caldera,  or SuSe.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.