Bug 1855136 - paring errors in prometheus-operator container
Summary: paring errors in prometheus-operator container
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Simon Pasquier
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-09 04:11 UTC by Junqi Zhao
Modified: 2020-10-27 16:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:13:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
prometheus-operator container logs (131.30 KB, text/plain)
2020-07-09 04:11 UTC, Junqi Zhao
no flags Details
monitoring dump file (1.40 MB, application/gzip)
2020-07-09 04:12 UTC, Junqi Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift prometheus-operator pull 79 0 None closed Bug 1853007: Revert "Bug 1806541: Update prometheus-operator to 0.40.0" 2020-11-03 15:11:35 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:13:30 UTC

Description Junqi Zhao 2020-07-09 04:11:26 UTC
Created attachment 1700377 [details]
prometheus-operator container logs

Description of problem:
check prometheus-operator pod logs, there are paring errors, more details please see from the attached files
# oc -n openshift-monitoring logs prometheus-operator-85f7d8ddbb-4z44r -c prometheus-operator
E0709 02:50:47.028404       1 reflector.go:178] github.com/coreos/prometheus-operator/pkg/prometheus/operator.go:479: Failed to list *v1.PodMonitor: resourceVersion: Invalid value: "10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362/10362": strconv.ParseUint: parsing

E0709 02:54:38.105102       1 reflector.go:178] github.com/coreos/prometheus-operator/pkg/prometheus/operator.go:478: Failed to list *v1.ServiceMonitor: resourceVersion: Invalid value: "21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779": strconv.ParseUint: parsing "21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779/21779": invalid syntax

prometheus-operator version v0.38.1
# oc -n openshift-monitoring get deploy prometheus-operator -oyaml | grep labels -A3
  labels:
    app.kubernetes.io/component: controller
    app.kubernetes.io/name: prometheus-operator
    app.kubernetes.io/version: v0.38.1

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-07-233934

How reproducible:
always

Steps to Reproduce:
1. check prometheus-operator pod logs
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Junqi Zhao 2020-07-09 04:12:18 UTC
Created attachment 1700378 [details]
monitoring dump file

Comment 6 Junqi Zhao 2020-07-14 02:00:50 UTC
Tested with 4.6.0-0.nightly-2020-07-13-203610, Prometheus Operator 0.38.1, there is not paring error

Comment 8 errata-xmlrpc 2020-10-27 16:13:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.