Bug 185527 - (u)mount causes hald & avc messages to console
(u)mount causes hald & avc messages to console
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-03-15 10:21 EST by Prarit Bhargava
Modified: 2013-03-13 00:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 07:49:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-03-15 10:21:14 EST
Description of problem: 
 
mount and umount cause auditd errors to be displayed on the console.   
 
Version-Release number of selected component (if applicable): laus-0.1-66RHEL3 
 
How reproducible: 100% 
 
 
Steps to Reproduce: 
1. mount or umount an nfs dir 
2. 
3. 
   
Actual results: 
 
audit(1142217702.244:6): avc:  denied  { search } for  pid=2690 comm="hald" 
name="home" dev=dm-0 ino=11272193 scontext=system_u:system_r:hald_t:s0 
tcontext=system_u:object_r:home_root_t:s0 tclass=dir 
 
Expected results: 
 
mount and umount are fairly common commands -- should we really be pumping 
error messages everytime we mount a filesystem?
Comment 1 Steve Grubb 2006-03-15 10:29:06 EST
Audit system just collects problems similar to syslog collects error messages.
The source of the problem seems to be a policy issue. Which SE Linux policy are
you running?
Comment 2 Prarit Bhargava 2006-03-15 10:39:18 EST
I'm running rawhide-latest, 
 
selinux-policy-2.2.23-15 
selinux-policy-targeted-2.2.23-15 
 
Comment 3 Daniel Walsh 2006-03-15 11:56:30 EST
Why is hal searching the home dir when a user does a mount?
Comment 4 David Zeuthen 2006-03-15 12:14:48 EST
Yes, we do search for a file ".created-by-hal" when a file system is unmounted.
We don't check for this when things are mounted.

We ought to restrict this check to

 1. When something is unmounted from "/media" 
 2. Only check if hal knew about this device

I will make this change upstream.

So I guess what you're seeing is that someone mounted something in their home
directory and then unmounted it. Prarit, can you confirm this?
Comment 5 Prarit Bhargava 2006-03-15 13:26:21 EST
>So I guess what you're seeing is that someone mounted something in their home 
directory and then unmounted it. Prarit, can you confirm this? 
 
Yep, that's what I was doing. 
 
P. 
Comment 6 Prarit Bhargava 2006-09-20 07:49:17 EDT
This is no longer occurring in the latest rawhide tree 20060919.

P.

Note You need to log in before you can comment on or make changes to this bug.