Bug 1855288 - Libvirt machine controller causes hypervisor URI to hang
Summary: Libvirt machine controller causes hypervisor URI to hang
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.6
Hardware: All
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: David Benoit
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks: 1857759
TreeView+ depends on / blocked
 
Reported: 2020-07-09 13:26 UTC by David Benoit
Modified: 2020-10-27 16:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:13:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-libvirt pull 199 0 None closed BUG 1855288: fix memory leak that leads to unresponsive libvirt URI 2020-07-28 07:12:26 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:13:30 UTC

Description David Benoit 2020-07-09 13:26:22 UTC
Description of problem:
When using libvirt IPI as a platform for openshift, the machine-controller does not terminate connections to the libvirt URI, leading to libvirtd becoming unresponsive after enough simultaneous connections occur.  Unresponsiveness is usually seen with about 5000 concurrent connections, which can occur in as little as an hour in a five node cluster.

Version-Release number of selected component (if applicable):
4.6 and earlier

How reproducible:
Always

Steps to Reproduce:
1. deploy openshift on libvirt (IPI)
2. netstat -tnaup | grep 16509 | grep ESTABLISHED | wc-l

Actual results:
Cluster deploys successfully, but the number of connections to the URI grows quickly.

Expected results:
Generally not more than 2-3 concurrent connections to the libvirt URI at a given time.

Additional info:
Fix submitted upstream.
https://github.com/openshift/cluster-api-provider-libvirt/pull/199

Comment 6 errata-xmlrpc 2020-10-27 16:13:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.