Bug 185537 - Keyboard is not correct during part of the installation process
Keyboard is not correct during part of the installation process
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 12:12 EST by David Tonhofer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 09:56:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2006-03-15 12:12:16 EST
I install FC4. During the first part of the installation process, I select
a 'swiss french keyboard'. The location is 'Luxembourg'.

Once installation has been completed, the machine reboots.

The second part of the installation process allows you to enter NTP servers.
The keyboard is now a 'french' one (i.e. its an AZERTY). Why 'french'? 
Maybe because of the location.

However, once the login screen shows up, the keyboard is now corretly set
to 'swiss french'.

Didn't try to reproduce it.
Comment 1 Chris Lumens 2006-03-18 22:03:02 EST
Please try with FC5 and let me know if this is fixed.  I've done a good amount
of work on keyboard stuff in anaconda and firstboot for this release.
Comment 2 David Tonhofer 2006-03-19 09:49:37 EST
FC5 is already out? I'm feeling the future shock. 

Ok, will test and be back.
Comment 3 David Tonhofer 2006-03-22 09:18:03 EST
Works A-OK in Fc5. 
Comment 4 David Tonhofer 2006-05-21 13:09:22 EDT
D'oh, it's back. It seems to depend on the machine (?) or on randomness:

I installed a Fc5 on an IBM (now Lenovo) ThinkCentre S50 8183 BBG: problem as
described above.

   A french keyboard is configured during firstboot.
   It should be configured to swiss-french.

At the same time, I installed it on a Fujitsu-Siemens Amilo G notebook.

   No problem encountered.
   A swiss-french is used during firstboot, as it should.



Note You need to log in before you can comment on or make changes to this bug.