Bug 185541 - standard tty becomes corrupt when using matrox dualhead and xorg
standard tty becomes corrupt when using matrox dualhead and xorg
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 12:25 EST by Bryan Christ
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 12:09:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log (67.93 KB, text/plain)
2006-03-16 11:12 EST, Bryan Christ
no flags Details

  None (edit)
Description Bryan Christ 2006-03-15 12:25:58 EST
Description of problem:

The standard tty becomes corrupt when using matrox (mga 450) in dualhead mode on
xorg.  X is configured for "individual desktops".  I have tried both symetrical
and asymetrical screen resoltions and neither configuration seems better or
worse.  If I boot to runlevel 3, the standard tty works fine.  It is only when I
start runlevel 5 and X is running that I have this problem.  The only way to
restore the standard tty is to reboot to runlevel 3.  Simply switcing to 'init
3' at runtime does not remedy the problem nor does issuing the 'reset' command.

Version-Release number of selected component (if applicable):

xorg-x11-drivers-7.0-2
xorg-x11-drv-mga-1.2.1.3-1.2

How reproducible:  Every time.

Steps to Reproduce:
1.  Install a matrox g450 in your system.
2.  Plug in two monitors
3.  Configure dualhead with "individual desktops" using configuration utility
located in Gnome Panel->System->Display
4.  Restart X as instructed
5.  Press ctrl+alt+f1 and notice the corrupt tty console text
  
Actual results:

Expected results:

Additional info:
Comment 1 Bryan Christ 2006-03-15 12:46:50 EST
Was able to "work around" the situation by setting vga=785 at boot time.  Still
seems like a problem that needs fixing, but maybe not so high a priority.
Comment 2 Mike A. Harris 2006-03-16 01:12:15 EST
Attach your X server log and config file from a session in which the problem
manifests.

Have you installed the Matrox hallib?
Comment 3 Bryan Christ 2006-03-16 10:36:59 EST
Where can I get this Matrox halllib from?  Is it available through yum?  What
does it do?  Are you asking me to install it or are you just wanting to know if
I already have it installed?  Sorry for the many questions.  I will send the X
server log shortly.
Comment 4 Bryan Christ 2006-03-16 11:12:39 EST
Created attachment 126228 [details]
xorg log
Comment 5 Bryan Christ 2006-03-16 11:16:05 EST
In order to generate the log file with the error, I needed to reboot the system
because my console was running in framebuffer mode (per comment 1).  Immediately
after clicking reboot, I noticed the machine behaved quite different.  Normally,
I would be able to watch the initscripts run and all the services shutdown
before reboot.  Instead, a big, grey triangle appeared on my screen.  I could
tell the scripts were running in the background because my HD LED was blinking.
 Evenutally the machine rebooted.  This behavior happens only when I use a vga=
paramenter for framebuffer console.
Comment 6 Mike A. Harris 2006-03-17 04:10:07 EST
(In reply to comment #3)
> Where can I get this Matrox halllib from?

I plead the 5th amendment.  (Even though I'm Canadian)  ;o)

> Is it available through yum?

No.

> What does it do?

Black magic.  Wether good or bad, I can not say.


> Are you asking me to install it

No, I would never do that, as it is proprietary 3rd party software which
we do not supply nor support.


> or are you just wanting to know if I already have it installed?

Yes, because we do not support it, so if it was installed, then any
problems that might be encountered need to be reported directly to
the vendor who supplies the hallib, as we do not have the source code
and do not support it.  ;)


> Sorry for the many questions.  I will send the X
> server log shortly.

No problem.  Thanks for the updates.
Comment 7 Mike A. Harris 2006-03-17 04:56:19 EST
Ok, I've reviewed your log.  It appears that you're using 2 flat panel displays:

(II) MGA(0): Monitor name: COMPAQTFT7020
(II) MGA(1): Monitor name: HP vs15


The mga driver does not support dualhead properly on such configurations.
Generally, the unsupported "hallib" module is required to get proper working
dualhead DVI support.  This is documented in the mga manpage I believe.

Since you claim it seems to work properly in runlevel 3 however, it would
seem reasonable that it should also work in runlevel 5.



ajax: Do you have a G450 revision 82 laying around?

Comment 8 Bryan Christ 2006-03-17 16:33:14 EST
Actually, I am not using DVI.  My mga 450 has 2 analog connectors (no DVI) by
which my flat panels are connected.  I looked at the mga man pages and found
nothing specific to my situation.  The only related clause which I found was...

"The  second  head  of dual-head cards is supported for the G450 and G550.  
Support  for  the  second  head  on  G400  cards requires  a  binary-only 
"mga_hal" module that is available from Matrox <http://www.matrox.com>, and may
be  on  the  CD  supplied with  the card.  That module also provides various
other enhancements, and may be necessary to use the DVI  (digital)  output  on
the G550 (and other cards)."
Comment 9 David Lawrence 2006-04-18 16:39:05 EDT
NEEDINFO_ENG has been deprecated in favor of NEEDINFO or ASSIGNED. Changing
status to ASSIGNED for ENG review.
Comment 10 Bryan Christ 2007-02-02 11:08:32 EST
This appears to be fixed in Fedora Core 6.

Note You need to log in before you can comment on or make changes to this bug.