Bug 1855428 - F33FailsToInstall: electrum
Summary: F33FailsToInstall: electrum
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: electrum
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Timothy Redaelli
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1893084 (view as bug list)
Depends On: 1785253
Blocks: F33FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-07-09 20:35 UTC by Igor Raits
Modified: 2021-04-02 17:14 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-02 17:14:52 UTC
Type: ---


Attachments (Terms of Use)

Description Igor Raits 2020-07-09 20:35:14 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain@fedoraproject.org).

Your package (electrum) Fails To Install in Fedora 33:

can't install electrum:
  - nothing provides python3.9dist(aiohttp-socks) >= 0.3 needed by electrum-4.0.2-1.fc33.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/rawhide-gating/multi-builds/

Thanks!

Comment 1 Ben Cotton 2020-08-11 13:46:21 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 2 malsworn_deliquesces 2020-09-30 20:17:14 UTC
I suspect this issue is blocking the upgrade to Fedora 33 (beta) for me, with the following issue:

Error: 
 Problem: problem with installed package electrum-3.3.4-6.fc32.noarch
  - electrum-3.3.4-6.fc32.noarch does not belong to a distupgrade repository
  - nothing provides python3.9dist(aiohttp-socks) >= 0.3 needed by electrum-4.0.2-2.fc33.noarch
  - nothing provides python3.9dist(dnspython) < 2 needed by electrum-4.0.2-2.fc33.noarch

Comment 3 Jonny Heggheim 2020-10-02 12:06:14 UTC
I have asked the maintainer of aiohttp-socks to update that library.

Comment 4 Fedora Admin user for bugzilla script actions 2020-10-26 02:51:51 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 5 Patrick C. F. Ernzer 2020-10-28 12:58:36 UTC
seems it also neeeds dnspython < 2

 Problem: conflicting requests
  - nothing provides python3.9dist(aiohttp-socks) >= 0.3 needed by electrum-4.0.2-2.fc33.noarch
  - nothing provides python3.9dist(dnspython) < 2 needed by electrum-4.0.2-2.fc33.noarch

Comment 6 ufa 2020-10-31 14:10:31 UTC
Not upgrading because of this bug, show stopper :(
It seems a lot of time since July, will it be resolved in near future?

Comment 7 Jonny Heggheim 2020-11-01 11:02:35 UTC
The package have been orphaned and is waiting for a new maintainer to update the package

Comment 8 ufa 2020-11-02 14:38:05 UTC
(In reply to Jonny Heggheim from comment #7)
> The package have been orphaned and is waiting for a new maintainer to update
> the package

Thank you. There's an AppImage in https://electrum.org/#download. Working fine on f33 (using it for now, just chmod +x it and run))

Comment 9 Artem S. Tashkinov 2020-11-16 12:32:36 UTC
Probably depends on:

https://bugzilla.redhat.com/show_bug.cgi?id=1785253

python-dns in Fedora 33 is already at version 2.0.0, but Electrum supports only version 1.16.0.

The DNS python package is being tracked here: https://github.com/spesmilo/electrum/issues/6538

Comment 10 Fedora Admin user for bugzilla script actions 2020-11-29 14:52:05 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 11 Timothy Redaelli 2020-12-10 11:56:36 UTC
*** Bug 1893084 has been marked as a duplicate of this bug. ***

Comment 12 Jonny Heggheim 2020-12-10 12:02:33 UTC
>   - nothing provides python3.9dist(dnspython) < 2 needed by

dnspython 2 have been merged into upstream master https://github.com/spesmilo/electrum/pull/6828

Comment 13 Fedora Update System 2020-12-10 15:35:12 UTC
FEDORA-2020-792b9f354d has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-792b9f354d

Comment 14 Fedora Update System 2020-12-11 00:59:31 UTC
FEDORA-2020-792b9f354d has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-792b9f354d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-792b9f354d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2020-12-15 01:21:49 UTC
FEDORA-2020-792b9f354d has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.