Bug 1855491 - [sriov] unlimit the max allowed mtu value in sriov network node policy
Summary: [sriov] unlimit the max allowed mtu value in sriov network node policy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.6.0
Assignee: zenghui.shi
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks: 1855492 1855493
TreeView+ depends on / blocked
 
Reported: 2020-07-10 00:51 UTC by zenghui.shi
Modified: 2020-10-27 16:13 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1855492 1855493 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:13:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:13:36 UTC

Description zenghui.shi 2020-07-10 00:51:36 UTC
Description of problem:


Currently SriovNetworkNodePolicy CRD limits the mtu value to be in the range of:
1 <= mtu <= 9000,  but user may want to set mtu outside of the allowed range, such as 9100. 

Version-Release number of selected component (if applicable):
4.6

How reproducible:
always

Steps to Reproduce:
1. create a SriovNetworkNodePolicy CR with mtu set to 9100
2.
3.

Actual results:
SriovNetworkNodePolicy CR is rejected


Expected results:
SriovNetworkNodePolicy CR is accepted

Additional info:

Comment 1 zhaozhanqi 2020-07-10 03:50:21 UTC
Verified this bug 

  - Vfs:
    - deviceID: 154c
      driver: iavf
      mtu: 9100
      pciAddress: 0000:3b:02.0
      vendor: "8086"
      vfID: 0
    - deviceID: 154c
      driver: iavf
      mtu: 9100
      pciAddress: 0000:3b:02.1
      vendor: "8086"
      vfID: 1

Comment 4 errata-xmlrpc 2020-10-27 16:13:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.