Bug 185550 - rpmbuild fails: guest-PAE nonint_oldconfig CONFIG_DEBUG_SLAB_LEAK
rpmbuild fails: guest-PAE nonint_oldconfig CONFIG_DEBUG_SLAB_LEAK
Status: CLOSED DUPLICATE of bug 182950
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 13:53 EST by John Reiser
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 19:18:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2006-03-15 13:53:27 EST
Description of problem:
rpmbuild fails to rebuild an i686 kernel .2054_FC5


Version-Release number of selected component (if applicable):
kernel-2.6.15-1.2054_FC5.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm --install kernel-2.6.15-1.2054_FC5.src.rpm
2. cd SPECS; rpmbuild -ba --target i686 kernel-2.6.spec
3.
  
Actual results:
+ mv kernel-2.6.15-i686-guest-PAE.config .config
++ head -1 .config
++ cut -b 3-
+ Arch=i386
+ make ARCH=i386 nonint_oldconfig
.config:2564:warning: trying to reassign symbol NI5010
.config:2567:warning: trying to reassign symbol AT1700
   ...
.config:3006:warning: trying to reassign symbol DVB
CONFIG_DEBUG_SLAB_LEAK
make[1]: *** [nonint_oldconfig] Error 1
make: *** [nonint_oldconfig] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.97488 (%prep)

Expected results:
successful rebuild

Additional info:
Comment 1 John Reiser 2006-03-15 19:18:20 EST
Stale kernel*.config in SOURCES directory got propagated into the BUILD
directory.    Building with --rmsource will help avoid trouble in the next build
(but not the current build), but also destroys the otherwise-useful caching
effect for sequential builds of sugsequent kernel-*.src.rpm.  Building with
--clean does not help because the problem originates in SOURCES, not in BUILD.

*** This bug has been marked as a duplicate of 182950 ***

Note You need to log in before you can comment on or make changes to this bug.