Bug 1855503 - OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '7.9', '--arch', 'x86_64', ...
Summary: OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/an...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.9
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:938da3147491bbcf73e1d017058...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-10 03:16 UTC by Edward Ng
Modified: 2020-07-14 07:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-14 07:23:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: anaconda-tb (1.00 MB, text/plain)
2020-07-10 03:16 UTC, Edward Ng
no flags Details
File: anaconda.log (37.63 KB, text/plain)
2020-07-10 03:16 UTC, Edward Ng
no flags Details
File: environ (492 bytes, text/plain)
2020-07-10 03:16 UTC, Edward Ng
no flags Details
File: lsblk_output (1.98 KB, text/plain)
2020-07-10 03:16 UTC, Edward Ng
no flags Details
File: nmcli_dev_list (2.45 KB, text/plain)
2020-07-10 03:16 UTC, Edward Ng
no flags Details
File: os_info (569 bytes, text/plain)
2020-07-10 03:16 UTC, Edward Ng
no flags Details
File: program.log (44.23 KB, text/plain)
2020-07-10 03:16 UTC, Edward Ng
no flags Details
File: storage.log (119.19 KB, text/plain)
2020-07-10 03:16 UTC, Edward Ng
no flags Details
File: syslog (252.19 KB, text/plain)
2020-07-10 03:17 UTC, Edward Ng
no flags Details
File: ifcfg.log (10.39 KB, text/plain)
2020-07-10 03:17 UTC, Edward Ng
no flags Details
File: packaging.log (472.67 KB, text/plain)
2020-07-10 03:17 UTC, Edward Ng
no flags Details

Description Edward Ng 2020-07-10 03:16:50 UTC
Description of problem:
Anaconda error seen during a normal install.  Happened 5 out of 5 times on this server  with different installation options 
(i.e. automatic partitioning, custom partitioning, etc).  RHEL7.7 installs fine on this system.  

Version-Release number of selected component:
anaconda-21.48.22.159-1

The following was filed automatically by anaconda:
anaconda 21.48.22.159-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 415, in next
    (self._argv, self._proc.returncode))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1586, in install
    for line in execReadlines("/usr/libexec/anaconda/anaconda-yum", args):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 252, in doInstall
    payload.install()
  File "/usr/lib64/python2.7/threading.py", line 765, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: process '['/usr/libexec/anaconda/anaconda-yum', '--config', '/tmp/anaconda-yum.conf', '--tsfile', '/mnt/sysimage/anaconda-yum.yumtx', '--rpmlog', '/tmp/rpm-script.log', '--installroot', '/mnt/sysimage', '--release', '7.9', '--arch', 'x86_64', '--macro', '__dbi_htconfig', 'hash nofsync %{__dbi_other} %{__dbi_perms}', '--macro', '__file_context_path', '/etc/selinux/targeted/contexts/files/file_contexts']' exited with status 1

Additional info:
addons:         org_fedora_oscap, com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=RHEL-7.9\x20Server.x86_64 selinux=0 modprobe.blacklist=qed,qede,qedf,qedi,qedr
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-1152.el7.x86_64
product:        Red Hat Enterprise Linux 7
release:        Red Hat Enterprise Linux ComputeNode release 7.9 Beta (Maipo)
release_type:   pre-release
reproducible:   Not sure how to reproduce the problem
type:           anaconda
version:        7.9

Comment 1 Edward Ng 2020-07-10 03:16:51 UTC
Created attachment 1700511 [details]
File: anaconda-tb

Comment 2 Edward Ng 2020-07-10 03:16:53 UTC
Created attachment 1700512 [details]
File: anaconda.log

Comment 3 Edward Ng 2020-07-10 03:16:54 UTC
Created attachment 1700513 [details]
File: environ

Comment 4 Edward Ng 2020-07-10 03:16:55 UTC
Created attachment 1700514 [details]
File: lsblk_output

Comment 5 Edward Ng 2020-07-10 03:16:56 UTC
Created attachment 1700515 [details]
File: nmcli_dev_list

Comment 6 Edward Ng 2020-07-10 03:16:57 UTC
Created attachment 1700516 [details]
File: os_info

Comment 7 Edward Ng 2020-07-10 03:16:58 UTC
Created attachment 1700517 [details]
File: program.log

Comment 8 Edward Ng 2020-07-10 03:16:59 UTC
Created attachment 1700518 [details]
File: storage.log

Comment 9 Edward Ng 2020-07-10 03:17:00 UTC
Created attachment 1700519 [details]
File: syslog

Comment 10 Edward Ng 2020-07-10 03:17:01 UTC
Created attachment 1700520 [details]
File: ifcfg.log

Comment 11 Edward Ng 2020-07-10 03:17:02 UTC
Created attachment 1700521 [details]
File: packaging.log

Comment 13 Jan Stodola 2020-07-10 08:17:20 UTC
Can you please select "Test this media & install Red Hat Enterprise Linux 7.9" when booting from the DVD media and confirm it reports success for the check?
Could you please provide MD5/SHA256 checksum of the downloaded ISO file?

So far I wasn't able to reproduce this problem.

Comment 14 Edward Ng 2020-07-10 20:50:39 UTC
It appears we had a bad ISO.  Re-downloaded the ISO off the Redhat FTP site and the problem is no longer seen.  Please go ahead and close.  Sorry for the churn.

Comment 15 Jan Stodola 2020-07-14 07:23:12 UTC
Closing this bug based on comment 14.


Note You need to log in before you can comment on or make changes to this bug.