Bug 1855567 - console-operator is updating config.openshift.io objects for no apparent reason
Summary: console-operator is updating config.openshift.io objects for no apparent reason
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1853270
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-10 08:36 UTC by OpenShift BugZilla Robot
Modified: 2020-07-22 12:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-22 12:20:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 446 None closed [release-4.5] Bug 1855567: Update console config on change 2020-07-21 12:56:04 UTC
Red Hat Product Errata RHBA-2020:2956 None None None 2020-07-22 12:21:05 UTC

Description OpenShift BugZilla Robot 2020-07-10 08:36:17 UTC
+++ This bug was initially created as a clone of Bug #1853270 +++

Cluster console object is being updated every second, although 

Steps To Reproduce:
1. Administration -> Cluster Settings
2. Global Configuration -> Console
3. Switch to Yaml view

After a couple of seconds "This object has been updated" message would appear. revisionVersion is bumped although no changes to configuration have been made.

This makes unnecessary load on apiserver and etcd

--- Additional comment from jhadvig@redhat.com on 2020-07-10 08:07:22 UTC ---

Waiting for bug to get verified. Adding UpcomingSprint to have it reevaluated in the next cycle.

Comment 3 Yanping Zhang 2020-07-17 03:38:51 UTC
Checked on 4.6 cluster with payload 4.6.0-0.nightly-2020-07-16-162619.
1.Go to Administration -> Cluster Settings
2.Click on Global Configuration -> Console
3. Switch to Yaml view, and wait for a couple of seconds, if no changes to configuration, will not show "This object has been updated" message.
The bug is fixed.

Comment 4 Yanping Zhang 2020-07-17 04:05:17 UTC
Sorry, cluster info in Comment 3 is not correct, the bug is verified on 4.5 cluster with payload 4.5.0-0.nightly-2020-07-16-193418.

Comment 6 errata-xmlrpc 2020-07-22 12:20:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2956


Note You need to log in before you can comment on or make changes to this bug.