Bug 185561 - update and use setuptools
update and use setuptools
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-cheetah (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Bonnet
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 15:34 EST by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 18:32:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update to latest version and use setuptools (2.70 KB, patch)
2006-03-15 15:34 EST, Patrice Dumas
no flags Details | Diff

  None (edit)
Description Patrice Dumas 2006-03-15 15:34:30 EST
Description of problem:

I am trying to use a setuptools based program. But it fails with Cheetah not
installed although it is installed. I think that it comes from the fact that the
setuptools related stuff from Cheetah isn't installed. So I propose this diff
for the Cheetah spec file that could be used to update Cheetah to the latest
upstream release and set setuptools

Version-Release number of selected component (if applicable):

1.0-2

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2006-03-15 15:34:30 EST
Created attachment 126168 [details]
update to latest version and use setuptools
Comment 2 Mike Bonnet 2006-03-21 13:29:51 EST
I can't find any other packages in Extras that include the extra metadata for
setuptools.  This metadata is only necessary if you're distributing your pakcage
in .egg format, and so is inappropriate for inclusion in an RPM-based
distribution, which maintains its own metadata.  Note that I'm waiting for the
2.0 GA release of Cheetah before I update the package version (hopefully soon).
Comment 3 Patrice Dumas 2006-03-21 16:07:10 EST
It seems that setuptool based packaged search for dependencies informations even
if a package has been installed with --single-version-externally-managed. 

With the paster script from python-paste-script, I get this with 1.0-2.fc5:
[dumas@localhost ~]$ paster 
Traceback (most recent call last):
  File "/usr/bin/paster", line 5, in ?
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 2356, in ?
    working_set.require(__requires__)
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 585, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 483, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: Cheetah


With the python-cheetah I did myself it shows the paster help message, as expected.

The python paste and paste script srpms I use are at
http://www.environnement.ens.fr/perso/dumas/fc-srpms/python-paste-0.5-1.src.rpm
http://www.environnement.ens.fr/perso/dumas/fc-srpms/python-paste-script-0.5-1.src.rpm


I don't know a lot about python, so it is very possible that I am doing
something wrong...
Comment 4 Mike Bonnet 2006-04-03 18:32:12 EDT
I think python-paste-script's use of pkg_resources is just flawed.  It's
duplicating data that is already managed by RPM.  Other python packages just
import the modules they need, confident that they've been installed already
because of RPM dependencies.  I'm not sure if there's a good way to make
pkg_resources and RPM live together happily, but I'd suggest removing the
"install_requires" section from setup.py as a starting point, and see if that
makes any difference.  In the meantime, this looks like a bug either with
python-paste-script or pkg_resources, so I'm closing as NOTABUG.  I'll update
python-cheetah to 2.0 as soon as 2.0 GA is released.

Note You need to log in before you can comment on or make changes to this bug.