Bug 185562 - gnome-pilot crashes just attaching my lifedrive to the usb cable
gnome-pilot crashes just attaching my lifedrive to the usb cable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-pilot (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-15 15:38 EST by Thomas J. Baker
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: gnome-pilot-2.0.15-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 12:58:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
typescript of gdb'ing gpilotd (8.54 KB, text/plain)
2006-03-15 15:38 EST, Thomas J. Baker
no flags Details

  None (edit)
Description Thomas J. Baker 2006-03-15 15:38:38 EST
Description of problem:

gpilotd crashes when I attach my lifedrive to the usb cable. I'll include a gdb
trace. What's worse, if I restart gpilotd while the lifedrive is still attached,
it crashes the lifedrive! This did not happen with fc4, if that's any help.

Version-Release number of selected component (if applicable):

gnome-pilot-2.0.13-7.fc5.4

How reproducible:

Everytime so far.

Steps to Reproduce:
1. Configure gpilotd for a usb lifedrive
2. connect lifedrive
3.
  
Actual results:

gpilotd crashes

Expected results:

gpilotd doesn't crash. a sync possibly occurs.

Additional info:

I can test anything you need me to.
Comment 1 Thomas J. Baker 2006-03-15 15:38:38 EST
Created attachment 126169 [details]
typescript of gdb'ing gpilotd
Comment 2 Matt Davey 2006-03-16 19:09:07 EST
Hi,
This would appear to be a pilot-link bug that has been fixed in CVS:
http://bugs.pilot-link.org/1591
Comment 3 Thomas J. Baker 2006-03-23 09:07:29 EST
Changed version from devel to fc5.
Comment 4 Nigel Metheringham 2006-03-26 07:39:32 EST
Suggest this is a duplicate of Bugzilla #186779 
Patch attached to that report.
Comment 5 Nigel Metheringham 2006-03-26 07:42:35 EST
[Repeat of previous comment with formatting fixed so BZ makes the links]
Suggest this is a duplicate of Bug #186779 
Patch attached to that report.

Comment 6 Matthew Barnes 2006-12-18 10:16:45 EST
Does this bug still exist in Fedora Core 6 using gnome-pilot-2.0.15?
Comment 7 Thomas J. Baker 2006-12-19 08:49:59 EST
I just tried and it doesn't crash anything anymore. I got network syncing to
work fine. No luch with USB syncing though. I read on the pilot list that this
new version is/should/has an option to use a userspace driver. Is that the case
with this fedora version? Should I blacklist the pilot modules to get usb
syncing to work? 
Comment 8 Matthew Barnes 2006-12-19 12:21:12 EST
I honestly have no idea.  Maybe Matt Davey can answer that.  CC'ing him.
Comment 9 Matt Davey 2006-12-19 12:47:48 EST
pilot-link 0.12.x supports libusb syncing, assuming it has been compiled in.
libusb syncing is well worth using, for the speedup and for avoiding some
problems with udev and the ttyUSB devices.

There's a libusb HOWTO you can find easily enough on pilot-link.org.

You can test with "pilot-xfer -p usb: -l"

I seem to remember issues with the lifedrive (usb connections made without
hotsync being started).  If you have trouble, the pilot-link-general list is
probably the best place to go for help.
Comment 10 Matthew Barnes 2006-12-19 12:58:18 EST
I'm closing this bug since the crash seems to have been fixed in Fedora Core 6.
 Feel free to re-open this if you see the same crash with gnome-pilot-2.0.15, or
open a new bug report if there are issues with USB syncing.

Note You need to log in before you can comment on or make changes to this bug.