Bug 1855704
| Summary: | failed to get openstack Terraform variables: unable to parse certificate, please check the cacert section of clouds.yaml .. with empty line in certificate.pem file | ||
|---|---|---|---|
| Product: | OpenShift Container Platform | Reporter: | OpenShift BugZilla Robot <openshift-bugzilla-robot> |
| Component: | Installer | Assignee: | Pierre Prinetti <pprinett> |
| Installer sub component: | OpenShift on OpenStack | QA Contact: | David Sanz <dsanzmor> |
| Status: | CLOSED WONTFIX | Docs Contact: | |
| Severity: | low | ||
| Priority: | low | CC: | m.andre, pprinett |
| Version: | 4.4 | Keywords: | UpcomingSprint |
| Target Milestone: | --- | ||
| Target Release: | 4.5.z | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: |
Cause: A programming error in the cacert parsing was causing an error when two end-of-line character sequences followed a certificate
Consequence: A cacert trustbundle with two EOLs caused the installation to fail.
Fix: The cacert trustbundle parser is now ignoring invisible characters.
Result: The cacert trustbundle can now feature an arbitrary number of EOL char sequences before, between or after the certificates.
|
Story Points: | --- |
| Clone Of: | Environment: | ||
| Last Closed: | 2020-07-27 08:36:54 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1813354 | ||
| Bug Blocks: | |||
|
Comment 2
Pierre Prinetti
2020-07-27 08:36:54 UTC
|