Bug 1855812 - EventListener page whitescreens if Route isn't fully created
Summary: EventListener page whitescreens if Route isn't fully created
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.z
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1855811
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-10 14:58 UTC by Andrew Ballantyne
Modified: 2020-08-17 19:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1855811
Environment:
Last Closed: 2020-08-10 13:50:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
EventListener page not whitescreens if Route isn't fully created (61.31 KB, image/png)
2020-08-03 12:51 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5946 None closed Bug 1855812: Allow Tekton Event Listeners to render without a full route 2020-08-17 19:18:14 UTC
Red Hat Product Errata RHBA-2020:3188 None None None 2020-08-10 13:50:44 UTC

Description Andrew Ballantyne 2020-07-10 14:58:56 UTC
+++ This bug was initially created as a clone of Bug #1855811 +++

Description of problem:

EventListener page whitescreens when it loads while the Route is still waiting back for a status.


Steps to Reproduce
1. Create EventListener
2. Go to the details page of the particular EventListener 
3. Notice the page doesn't load

Actual results:
The page doesn't load

Expected results:
The page should load without any errors

Reproducibility (Always/Intermittent/Only Once):  Always
Build Details: 4.6.0-0.nightly-2020-06-18-182334

Comment 4 spathak@redhat.com 2020-08-03 12:51:16 UTC
Created attachment 1703291 [details]
EventListener page not whitescreens if Route isn't fully created

Comment 5 spathak@redhat.com 2020-08-03 12:53:29 UTC
Verified on build version: 4.5.0-0.nightly-2020-08-01-204100
Browser version: Chrome 76

Comment 6 spathak@redhat.com 2020-08-03 12:53:30 UTC
Verified on build version: 4.5.0-0.nightly-2020-08-01-204100
Browser version: Chrome 76

Comment 8 errata-xmlrpc 2020-08-10 13:50:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3188


Note You need to log in before you can comment on or make changes to this bug.