Bug 1855820 - Pipeline Trigger Resource YAMLs should be Editable
Summary: Pipeline Trigger Resource YAMLs should be Editable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.z
Assignee: Andrew Ballantyne
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1855818
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-10 15:18 UTC by OpenShift BugZilla Robot
Modified: 2020-09-21 17:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-21 17:42:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Pipeline Trigger Resource YAML is Editable (582.79 KB, video/webm)
2020-09-16 22:56 UTC, spathak@redhat.com
no flags Details
Pipeline Trigger Resource YAML is Editable (582.79 KB, video/webm)
2020-09-16 22:58 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5947 None closed [release-4.5] Bug 1855820: Editable TT, EL, CTB, TB 2020-09-14 12:21:37 UTC
Red Hat Product Errata RHBA-2020:3719 None None None 2020-09-21 17:42:21 UTC

Description OpenShift BugZilla Robot 2020-07-10 15:18:34 UTC
+++ This bug was initially created as a clone of Bug #1855818 +++

Description of problem:
When I access a TriggerTemplate by clicking on the link to it in the Pipeline Details screen, I can then select the option to Edit the TriggerTemplate. This redirects me to a YAML editor but I can't save my changes.

Prerequisites (if any, like setup, operators/versions):
Pipelines Operator 1.0.1, OpenShift 4.5.0-rc.4

Steps to Reproduce
1. From the Pipelines list in the Developer console, click on a Pipeline that has a Trigger
2. Click on the TriggerTemplate
3. In the TriggerTemplate Details screen, select "Edit Trigger Template" from the dropdown menu
4. The YAML editor opens up but in read-only mode

Actual results:
The editor opens up in read-only mode. I can't do changes and there is no save button.

Expected results:
I should be able to edit the Trigger Template. If this screen is meant to be read-only, then perhaps the wording should change from "Edit Trigger Template" to "View Trigger Template YAML file"

Reproducibility (Always/Intermittent/Only Once):
Always

Build Details:
Additional info:
We should make all trigger resources editable at the same time:

Event Listener
Cluster Trigger Binding
Trigger Binding
(and) Trigger Template

Comment 3 spathak@redhat.com 2020-09-16 22:56:29 UTC
Created attachment 1715142 [details]
Pipeline Trigger Resource YAML is Editable

Comment 4 spathak@redhat.com 2020-09-16 22:58:53 UTC
Created attachment 1715143 [details]
Pipeline Trigger Resource YAML is Editable

Comment 5 spathak@redhat.com 2020-09-16 23:00:20 UTC
Verified on build version: 4.5.0-0.ci-2020-09-15-143038
Browser version: Chrome 84

Comment 7 errata-xmlrpc 2020-09-21 17:42:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3719


Note You need to log in before you can comment on or make changes to this bug.