Bug 1856001 - Use upstream default for --default-lv2-path to fix Ardour presets
Summary: Use upstream default for --default-lv2-path to fix Ardour presets
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lilv
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Guido Aulisi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-11 17:22 UTC by Sam Thursfield
Modified: 2020-07-16 01:14 UTC (History)
3 users (show)

Fixed In Version: lilv-0.24.6-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-16 01:14:31 UTC
Type: Bug


Attachments (Terms of Use)
Possible patch (1.21 KB, text/plain)
2020-07-11 17:22 UTC, Sam Thursfield
no flags Details

Description Sam Thursfield 2020-07-11 17:22:47 UTC
Created attachment 1700704 [details]
Possible patch

Description of problem:
On Fedora, Ardour doesn't see saved presets for LV2 plugins.

I reported this in the Ardour bug tracker and we determined that the problem is in the Fedora packaging of `lilv`.

Fedora passes --default-lv2-path=%{_libdir}/lv2

To fix the issue, we should use the upstream default which is: ~/.lv2:/usr/%{_libdir}/lv2:/usr/local/%{_libdir}/lv2


Version-Release number of selected component (if applicable):
0.24.6


How reproducible:
Always

Steps to Reproduce:
1. Open Ardour, add an LV2 plugin
2. Save a preset for the plugin.

Actual results:
Preset saved to disk in ~/.lv2 but doesn't appear in the UI.

Expected results:
Preset will appear in the UI.

Additional info:

Comment 1 Sam Thursfield 2020-07-11 17:23:05 UTC
Upstream (Ardour) bug is https://tracker.ardour.org/view.php?id=8280

Comment 2 Fedora Update System 2020-07-12 18:38:23 UTC
FEDORA-2020-0526a9cfe8 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-0526a9cfe8

Comment 3 Fedora Update System 2020-07-13 02:06:18 UTC
FEDORA-2020-0526a9cfe8 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-0526a9cfe8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-0526a9cfe8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-07-16 01:14:31 UTC
FEDORA-2020-0526a9cfe8 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.