Bug 1856014 - Regression: App crash/exit when clicking on View menu a few times
Summary: Regression: App crash/exit when clicking on View menu a few times
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: keepassxc
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-11 19:34 UTC by Dimitris
Modified: 2020-08-22 01:43 UTC (History)
2 users (show)

Fixed In Version: keepassxc-2.6.1-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-22 01:43:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Dimitris 2020-07-11 19:34:37 UTC
Description of problem:

App seems to crash after I click on View and/or its sub-menu choices a few times.

Version-Release number of selected component (if applicable):

keepassxc-2.6.0-1.fc32

How reproducible:

Every time

Steps to Reproduce:
1. View → Theme → Automatic is selected.
2. Click on View or View → Theme → Automatic a few times - no change in theme.
3. App stops

Actual results:

App exits

Expected results:

Should be a no-op since I'm not changing the theme.

Additional info:

Regression seems related to the new theme support in 2.6.

Comment 1 Dimitris 2020-07-11 19:37:06 UTC
Forgot to mention, the desktop (GNOME Wayland) is on the Adwaita-dark theme.

Comment 2 Mukundan Ragavan 2020-07-12 20:08:32 UTC
I cannot reproduce this at all.

I have tried several times switching from default "automatic" to "classic (platform native)" and back. I have also tried with and without "Compact mode". I have tried both Adwaita and Adwaita-Dark.


The only message I see when started from command line is this - 

qt.qpa.wayland: Wayland does not support QWindow::requestActivate()


I think this is something in your setup. Can you try this with a new user account on your system?

Comment 3 Dimitris 2020-07-13 05:10:02 UTC
With my regular user, running keepassxc from the command line and repeating the steps above:

$ keepassxc
QSocketNotifier: Can only be used with threads started with QThread
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setCompositionMode: Painter not active
The Wayland connection experienced a fatal error: Protocol error
Aborted

I also got more or less the same creash and output (minus the QPainter:: lines) with a brand new user.

Comment 4 Mukundan Ragavan 2020-07-15 22:00:36 UTC
Do you have all the qt components updated?

Comment 5 Dimitris 2020-07-15 22:43:12 UTC
(In reply to Mukundan Ragavan from comment #4)
> Do you have all the qt components updated?

As far as I can tell, yes:

$ dnf list installed *qt*
Installed Packages
adwaita-qt4.x86_64                                          1.1.3-2.fc32                                       @updates
adwaita-qt5.x86_64                                          1.1.3-2.fc32                                       @updates
dbusmenu-qt.x86_64                                          0.9.3-0.22.20160218.fc32                           @fedora 
gstreamer1-plugins-good-qt.x86_64                           1.16.2-2.fc32                                      @fedora 
ibus-qt.x86_64                                              1.3.3-24.fc32                                      @fedora 
qt.x86_64                                                   1:4.8.7-52.fc32                                    @fedora 
qt-common.noarch                                            1:4.8.7-52.fc32                                    @fedora 
qt-settings.noarch                                          32.0-3.fc32                                        @fedora 
qt-x11.x86_64                                               1:4.8.7-52.fc32                                    @fedora 
qt5-qtbase.x86_64                                           5.14.2-5.fc32                                      @updates
qt5-qtbase-common.noarch                                    5.14.2-5.fc32                                      @updates
qt5-qtbase-gui.x86_64                                       5.14.2-5.fc32                                      @updates
qt5-qtdeclarative.x86_64                                    5.14.2-1.fc32                                      @updates
qt5-qtsvg.x86_64                                            5.14.2-1.fc32                                      @updates
qt5-qtwayland.x86_64                                        5.14.2-3.fc32                                      @updates
qt5-qtx11extras.x86_64                                      5.14.2-1.fc32                                      @updates
qt5-qtxmlpatterns.x86_64                                    5.14.2-1.fc32                                      @updates
qt5-srpm-macros.noarch                                      5.14.2-3.fc32                                      @updates
quazip-qt5.x86_64                                           0.7.6-6.fc32                                       @fedora 
sni-qt.x86_64                                               0.2.7-0.4.20170217.fc32                            @fedora

$ dnf --refresh --enablerepo updates-testing list updates *qt*
Fedora 32 openh264 (From Cisco) - x86_64                                               4.7 kB/s | 986  B     00:00    
Fedora Modular 32 - x86_64                                                              62 kB/s |  16 kB     00:00    
Fedora Modular 32 - x86_64 - Updates                                                    39 kB/s |  16 kB     00:00    
Fedora 32 - x86_64 - Test Updates                                                       45 kB/s |  12 kB     00:00    
Fedora 32 - x86_64 - Updates                                                            54 kB/s |  15 kB     00:00    
Fedora 32 - x86_64                                                                      40 kB/s |  16 kB     00:00    
Error: No matching Packages to list

Comment 6 Mukundan Ragavan 2020-07-16 01:27:49 UTC
This is strange. My package versions are identical to what you have posted here but I cannot reproduce the crash (not in gnome or Xfce).

Comment 7 Mukundan Ragavan 2020-07-16 01:30:09 UTC
Can you try the official appimage from keepassxc website and see if you can reproduce this issue?

Download from here - https://keepassxc.org/download/#linux

Comment 8 Dimitris 2020-07-21 20:14:03 UTC
I reverted to the release 2.5.4-1.fc32 version but I see this in that version as well, in this case under slightly different steps: mouse around the `File` menu, then bring the pointer over to the `Entries` menu, then:

$ keepassxc
QSocketNotifier: Can only be used with threads started with QThread
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
The Wayland connection experienced a fatal error: Protocol error

Looks like a regression in Qt (Fedora 32 specific?)

Also, one thing possibly different between my setup and others who can't reproduce is the graphics - AMDGPU.  Can that be affecting rendering behavior under Wayland to cause this crash?

Comment 9 Germano Massullo 2020-07-21 21:26:36 UTC
Cannot reproduce on 2.6.0.

To get useful debug data:
# dnf debuginfo-install keepassxc
$ gdb keepassxc
(gdb) run
when it crashes:
(gdb) set print elements 0
(gdb) set print frame-arguments all
(gdb) thread apply all backtrace

Please note that you may get messages in GDB asking you to install debuginfos of related libraries. If it happens do it.

Comment 10 Fedora Update System 2020-08-20 09:01:04 UTC
FEDORA-2020-6a022d29c1 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-6a022d29c1

Comment 11 Fedora Update System 2020-08-21 01:17:44 UTC
FEDORA-2020-6a022d29c1 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-6a022d29c1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-6a022d29c1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Dimitris 2020-08-21 04:26:34 UTC
2.6.1-1.fc32 seems to fix this for me.

Comment 13 Fedora Update System 2020-08-22 01:43:09 UTC
FEDORA-2020-6a022d29c1 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.