Bug 185606 - Template file for libraries
Template file for libraries
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-rpmdevtools (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-16 00:48 EST by Ignacio Vazquez-Abrams
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.6-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-15 17:23:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Template for library spec files (1.07 KB, text/plain)
2006-03-16 00:48 EST, Ignacio Vazquez-Abrams
no flags Details

  None (edit)
Description Ignacio Vazquez-Abrams 2006-03-16 00:48:51 EST
Attached is a template that can be used for generating library spec files via
fedora-newrpmspec.
Comment 1 Ignacio Vazquez-Abrams 2006-03-16 00:48:51 EST
Created attachment 126197 [details]
Template for library spec files
Comment 2 Ville Skyttä 2006-03-16 02:40:16 EST
(Cc'ing the FE list for comments)

Looks useful.  I think this should be also automagically used for lib*, *-libs
and *-lib specfiles.  A quick look at the FC and FE package lists tells me that
this would result in few enough false positives.

Some comments:

I'm inclined to drop %{_datadir}/%{name} from the main package because 1) it's 
rarely used in library packages, and 2) library packages including such things
are not multilib parallel installable which I think is not something we want to
kind of encourage in a spec template.

Inclusion of *.pc files should walk hand in hand with Requires: pkgconfig in
-devel packages.  Do you think it would be a good idea to add that dependency in
the -devel boilerplate?  Another option IMO would be to drop the pkgconfig files
 from the template's %files list.

I'm not sure why installing *.m4 in /usr/share/aclocal doesn't usually in
packages get the same treatment as with pkgconfig through an added dependency on
automake, so maybe 1) leave it as is in the template, or 2) discuss about
"mandating" Requires: automake on packages that install stuff to /usr/share/aclocal?
Comment 3 Ville Skyttä 2006-04-02 18:02:58 EDT
Slightly modified version added to CVS (the project, not the packages dir). 
Comments welcome.
Comment 4 Ignacio Vazquez-Abrams 2006-04-14 08:34:14 EDT
Works for me.
Comment 5 Ville Skyttä 2006-05-15 17:23:00 EDT
Included in 1.6-1, which will soon hit the repos.

Note You need to log in before you can comment on or make changes to this bug.