Bug 185615 - pikdev fails to build on ppc because <sys/io.h> seems to not exist on this arch
pikdev fails to build on ppc because <sys/io.h> seems to not exist on this arch
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pikdev (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Alain Portal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F-ExcludeArch-ppc
  Show dependency treegraph
 
Reported: 2006-03-16 08:03 EST by Alain Portal
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.8.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 07:05:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain Portal 2006-03-16 08:03:19 EST
Description of problem:  
  
pikdev fails to build on ppc because <sys/io.h> don't exist in glibc for this  
arch.  
I know nothing about ppc computers, but they probably don't have I/O like PC. 
  
Version-Release number of selected component (if applicable):  
  
  
How reproducible:  
 
Compile pikdev 
  
Steps to Reproduce:  
1. ./configure 
2. make 
3.  
    
Actual results:  
 
gcc hardware.cc -c -Wall -pedantic -ansi -O2 -DPKP_VERSION=0.8.4 
In file included from hardware.cc:7: 
uparport.hh:21:21: error: sys/io.h: No such file or directory 
make: *** [hardware.o] Error 1 
  
Expected results:  
  
A binary 
 
Additional info:
Comment 1 David Woodhouse 2006-04-05 09:14:50 EDT
uparport.hh is for the ppdev devices -- it shouldn't be using direct hardware
mangling at all. If you just remove the offending #include, it appears to build
fine.
Comment 2 Alain Portal 2006-04-07 05:05:28 EDT
Sorry but because my english, I'm not sure to understand what you mean. 
Do I have to remove "#include <sys/io.h>" in uparport.hh? 
Comment 3 Alain Portal 2006-04-07 07:05:48 EDT
Seems to be the solution as built is OK. So close this bug.  

Note You need to log in before you can comment on or make changes to this bug.