Bug 1856156 - Pipeline Builder - Tasks Disconnect on Delete
Summary: Pipeline Builder - Tasks Disconnect on Delete
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.z
Assignee: Andrew Ballantyne
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1856155
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-13 01:00 UTC by OpenShift BugZilla Robot
Modified: 2020-09-14 14:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Failure to maintain the connection between nodes in the Pipeline Builder when deleting a middle node. This only occurred when a task that was to be deleted had a runAfter and was part of another's runAfter (ie they had more than one runAfter). Consequence: It would break the connection flow between the tasks Fix: Properly maintain the connection when a middle node was removed. Result: Maintains the connection during delete.
Clone Of:
Environment:
Last Closed: 2020-09-14 14:54:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
Pipeline Builder - Tasks doesn't Disconnect on Delete (374.48 KB, video/webm)
2020-09-09 21:29 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5955 None closed [release-4.5] Bug 1856156: Fixes deletion of node connected to a split node 2020-09-09 13:34:35 UTC
Red Hat Product Errata RHBA-2020:3618 None None None 2020-09-14 14:55:00 UTC

Description OpenShift BugZilla Robot 2020-07-13 01:00:38 UTC
+++ This bug was initially created as a clone of Bug #1856155 +++

Description:
Tasks rearrange incorrectly in Pipeline Builder page on adding or deleting tasks.

Deleting a sequential task in a parallel chain of tasks removes the connector between the involved parallel tasks
Adding a sequential task to one of independent chains of tasks causes shuffling in the row arrangements of the chains of tasks.

Build: 4.5.0-0.ci-2020-05-18-204038
Browser: Firefox (version 75)

Reproducibility: Always

Steps to reproduce:

1. go to Pipeline Page and click on Create Pipeline button
2. Add a task T1 and a sequential task T2 to it
3. Add a parallel task T11 to the first task
4. Add a sequential task T12 to the newly added parallel task T11
5. Remove the sequential task T12
6. Add more tasks to either of the chains of tasks

Actual Behaviour:

The parallel chain of tasks breaks off as an independent chain losing the connector between the parallel tasks.
On adding more tasks to either chain, the chains rearrange

Expected Behaviour:

The parallel tasks should be reconnected with the connector on deletion of a task
The positions of the chains should not rearrange

Comment 3 spathak@redhat.com 2020-09-09 21:29:26 UTC
Created attachment 1714346 [details]
Pipeline Builder - Tasks doesn't Disconnect on Delete

Comment 4 spathak@redhat.com 2020-09-09 21:30:05 UTC
Verified on Build version: 4.5.0-0.nightly-2020-09-08-123650
Browser version: Chrome 84

Comment 6 errata-xmlrpc 2020-09-14 14:54:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.9 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3618


Note You need to log in before you can comment on or make changes to this bug.