Bug 185622 - rkhunter-1.2.8-1.fc3 from FE uses /usr/lib64 on i386
rkhunter-1.2.8-1.fc3 from FE uses /usr/lib64 on i386
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rkhunter (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Houlette
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-16 09:06 EST by Nils Breunese
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: rkhunter-1.2.8-2.fc3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-19 10:49:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Breunese 2006-03-16 09:06:08 EST
Description of problem:

Today I ran yum update on FC3 server and it upgraded my rkhunter 1.2.7 package 
from the Atomic Rocket Turtle repository (http://3es.atomicrocketturtle.com/
atomic/art/3/RPMS/) to FE's 1.2.8. However, after this upgrade rkhunter is no 
longer working. I did an rpm -ql and saw files installed into /usr/lib64, while 
this is a i386 32-bit system.

Version-Release number of selected component (if applicable):

0:1.2.8-1.fc3

How reproducible:

Always.

Steps to Reproduce:
1. Install rkhunter 0:1.2.8-1.fc3 from Extras on a 32 bit system.
2. Run rkhunter
3. Error
  
Actual results:

Non-working rkhunter

Expected results:

Working rkhunter

Additional info:
Comment 1 Michael Schwendt 2006-03-16 12:08:14 EST
Packaging bug. The spec file contains

  BuildArch:      noarch

but uses %{_libdir} everywhere. It must not do this, since the build host
can be _any_ arch. If built on x86_64, for instance, libdir becomes /usr/lib64

The fix would be to either use %{_prefix}/lib instead of %{_libdir}
or to install the platform-independent Perl scripts into
%{_datadir}/rkhunter/scripts  instead, provided that they are found there.
Comment 2 Nils Breunese 2006-03-16 20:30:31 EST
Here is Atomic Rocket Turtle's spec file: http://3es.atomicrocketturtle.com/
packages/rkhunter/rkhunter.spec




Comment 3 Greg Houlette 2006-03-16 23:08:01 EST
Hmmm... It seems to only have affected the FC-3 build.  I'll make the correction
to the .spec file (using the %{_prefix} method) and propagate it into all the
branches and re-build.  This is my first encounter with the x86_64, so I didn't
know about this difference.  oops...
Comment 4 Greg Houlette 2006-03-18 10:45:02 EST
Well... I made the necessary changes, committed them, set about tagging for the
new builds and ran into a few roadblocks:

1) When I tried to build the new FC-3 RPM using the plague-client method (I have
verified that I am using the proper command line parameters) I get the following
failure in root.log:

http://buildsys.fedoraproject.org/logs/fedora-3-extras/6496-rkhunter-1.2.8-2.fc3/

/usr/sbin/mock-helper yum --installroot ...
file:///pub/fedora/linux/extras/3/x86_64/repodata/repomd.xml: [Errno 5] OSError:
[Errno 2] No such file or directory:
'/pub/fedora/linux/extras/3/x86_64/repodata/repomd.xml'
Trying other mirror.
Cannot open/read repomd.xml file for repository: extras
failure: repodata/repomd.xml from extras: [Errno 256] No more mirrors to try.

However, when I go look here:

http://fedoraproject.org/extras/3/x86_64/repodata/repomd.xml

the file in question seems to be present (whether this is the right place?).

Is this a probable issue with mirror synchronization?
(I have tried requeueing the job a couple of times, with the same results.)

2) While I was tagging, CVS was busy adding the FC-5 branch across all modules.
So guess what?  I tagged the devel branch of rkhunter with rkhunter-1_2_8-2_fc5
*_AFTER_* the FC-5 branch was copy/created.  Now after committing the changes
to the new FC-5 branch, I find that I can't tag it:

ERROR: The tag rkhunter-1_2_8-2_fc5 is already applied on a different branch
ERROR: You can not forcibly move tags between branches

And I can't rtag delete it either:

ERROR: Tag removal not allowed for tag rkhunter-1_2_8-2_fc5

I'm getting a login to the wiki so that I can post this to the CVSSyncNeeded
page but in the interim FC-5 and devel branches are a bit hosed.

This seemed like such an easy fix...
Comment 5 Michael Schwendt 2006-03-18 11:25:43 EST
Simply bump Release and tag again for FC-5 (and devel). Creation of the
FC-5 branch was announced on fedora-extras-list and fedora-maintainers
list.
Comment 6 Greg Houlette 2006-03-18 18:07:05 EST
Alright.  I seemed to have missed Ville's post about the forced update...

Thanks for the help with the FC-3 build BTW...

Note You need to log in before you can comment on or make changes to this bug.