Bug 1856251 - Integration tests for VM Environment flake on expect-vm-env-readable.sh expect script
Summary: Integration tests for VM Environment flake on expect-vm-env-readable.sh expec...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Tomas Jelinek
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-13 07:44 UTC by Radim Hrazdil
Modified: 2020-10-27 16:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:13:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5962 0 None closed Bug 1856251: fix test env expect script timeout 2020-08-21 07:15:04 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:21 UTC

Description Radim Hrazdil 2020-07-13 07:44:49 UTC
Description of problem:
When running the VM Environment tests
(frontend/packages/kubevirt-plugin/integration-tests/tests/vm.environment.scenario.ts) on internal cnv-qe executor machine,
frontend/packages/kubevirt-plugin/integration-tests/tests/vm.environment.scenario.ts fails on attempt to enter password

```
# Enter Password
expect $password_prompt {
    sleep $response_delay
    send -h "$password\n"
}
``` 



Version-Release number of selected component (if applicable):


How reproducible:
very often, not 100%

Steps to Reproduce:
1. execute VM Environment integration tests
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Guohua Ouyang 2020-07-22 07:05:27 UTC
move to verified as the PR is merged

Comment 6 errata-xmlrpc 2020-10-27 16:13:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.