Bug 1856267 - White screen when cancel Pipeline Create with open sidebar
Summary: White screen when cancel Pipeline Create with open sidebar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Christoph Jerolimov
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1856268
TreeView+ depends on / blocked
 
Reported: 2020-07-13 08:48 UTC by Christoph Jerolimov
Modified: 2020-10-27 16:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: JavaScript exception because of an internal state handling. Consequence: White screen (or Ops screen was shown) when cancel the Pipeline Create page when the sidebar was open. Fix: Improve internal state handling. Result: No exception was thrown and the Pipeline list is shown as expected.
Clone Of:
Environment:
Last Closed: 2020-10-27 16:13:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:21 UTC

Description Christoph Jerolimov 2020-07-13 08:48:32 UTC
Description of problem:
When creating a pipeline, open a sidebar and press cancel the Console "crashes" and shows just a white screen.

Version-Release number of selected component (if applicable):
4.6.0-0.ci-2020-07-06-063139

How reproducible:
Always

Steps to Reproduce:
1. Install OpenShift Pipelines operator (tested with 1.0.1)
2. Open the Developer perspective and select Pipeline from the navigation.
3. Select "Create Pipeline"
4. Select task "git-clone" from the task list
5. Click on task "git-clone" to open the config sidebar on the right side
6. Press cancel (on the bottom left) while the sidebar is open!

Actual results:
White screen with the following message in the browser log:

Uncaught TypeError: Cannot read property 'name' of undefined
    at TaskSidebar (:9000/static/pipeline-builder-page-909c555cb842a4083ed6.js:774)
    at renderWithHooks (vendors~main-da01bf789e9762cb7930.js:261216)
    at updateFunctionComponent (vendors~main-da01bf789e9762cb7930.js:263033)


Expected results:
That we route is switched back to the Pipeline list.

Additional info:

Comment 3 Abhishek K N 2020-07-17 11:21:50 UTC
Validated on following 4.6 build & it's working fine.

OpenShift Version: 4.6.0-0.ci-2020-07-10-095921

Kubernetes Version: v1.18.3

Comment 5 errata-xmlrpc 2020-10-27 16:13:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.