Bug 1856271 - multus network-metrics-daemon is trying to apply to Windows node
Summary: multus network-metrics-daemon is trying to apply to Windows node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Federico Paolinelli
QA Contact: Weibin Liang
URL:
Whiteboard:
: 1857241 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-13 08:57 UTC by gaoshang
Modified: 2020-10-27 16:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:13:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 708 0 None closed Bug 1856271: Make sure the network metrics pod runs only on linux nodes. 2021-02-17 22:00:24 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:21 UTC

Description gaoshang 2020-07-13 08:57:01 UTC
Description of problem:
Though Windows node has Taints:os=Windows:NoSchedule, multus is applying network-metrics-daemon to it

Version-Release number of selected component (if applicable):
# oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-07-10-114229   True        False         24h     Cluster version is 4.6.0-0.nightly-2020-07-10-114229

windows-machine-config-bootstrapper git commit: faf4c5e889bd663a021ef7f877ad0f337c121e62

How reproducible:
always

Steps to Reproduce:
1. Boostrap Windows node per https://github.com/openshift/windows-machine-config-bootstrapper/tree/master/tools/ansible, oc describe windows node, found network-metrics-daemon pod failed

# oc get node -l kubernetes.io/os=windows
NAME                                        STATUS   ROLES    AGE   VERSION
ip-10-0-55-138.us-east-2.compute.internal   Ready    worker   37m   v1.18.3

# oc describe node ip-10-0-55-138.us-east-2.compute.internal
...
Non-terminated Pods:          (1 in total)
  Namespace                   Name                            CPU Requests  CPU Limits  Memory Requests  Memory Limits  AGE
  ---------                   ----                            ------------  ----------  ---------------  -------------  ---
  openshift-multus            network-metrics-daemon-5hvqf    20m (1%)      0 (0%)      120Mi (1%)       0 (0%)         10m
...

# oc describe pod network-metrics-daemon-5hvqf -n openshift-multus
Name:         network-metrics-daemon-5hvqf
Namespace:    openshift-multus
Priority:     0
Node:         ip-10-0-55-138.us-east-2.compute.internal/10.0.55.138
Start Time:   Sat, 11 Jul 2020 11:21:55 -0400
Labels:       app=network-metrics-daemon
              component=network
              controller-revision-hash=67776c557
              openshift.io/component=network
              pod-template-generation=1
              type=infra
Annotations:  <none>
Status:       Pending
IP:           10.132.2.3
IPs:
  IP:           10.132.2.3
Controlled By:  DaemonSet/network-metrics-daemon
Containers:
  network-metrics-daemon:
    Container ID:  
    Image:         quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:b78fb952c0d054061ccf505cf18b099d6303d06d16cff4e12d24311e6e5be78a
    Image ID:      
    Port:          <none>
    Host Port:     <none>
    Command:
      /usr/bin/network-metrics
    Args:
      --node-name
      $(NODE_NAME)
    State:          Waiting
      Reason:       ImagePullBackOff
    Ready:          False
    Restart Count:  0
    Requests:
      cpu:     10m
      memory:  100Mi
    Environment:
      NODE_NAME:   (v1:spec.nodeName)
    Mounts:
      /var/run/secrets/kubernetes.io/serviceaccount from metrics-daemon-sa-token-2w9z8 (ro)
  kube-rbac-proxy:
    Container ID:  
    Image:         quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:985d38be2b84a7cd8088c4c9a0826c0eb14729137588ec3e748725b57994cd05
    Image ID:      
    Port:          8443/TCP
    Host Port:     0/TCP
    Args:
      --logtostderr
      --secure-listen-address=:8443
      --tls-cipher-suites=TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256,TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256,TLS_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256
      --upstream=http://127.0.0.1:9091/
      --tls-private-key-file=/etc/metrics/tls.key
      --tls-cert-file=/etc/metrics/tls.crt
    State:          Waiting
      Reason:       ImagePullBackOff
    Ready:          False
    Restart Count:  0
    Requests:
      cpu:        10m
      memory:     20Mi
    Environment:  <none>
    Mounts:
      /etc/metrics from metrics-certs (ro)
      /var/run/secrets/kubernetes.io/serviceaccount from metrics-daemon-sa-token-2w9z8 (ro)
Conditions:
  Type              Status
  Initialized       True 
  Ready             False 
  ContainersReady   False 
  PodScheduled      True 
Volumes:
  metrics-certs:
    Type:        Secret (a volume populated by a Secret)
    SecretName:  metrics-daemon-secret
    Optional:    false
  metrics-daemon-sa-token-2w9z8:
    Type:        Secret (a volume populated by a Secret)
    SecretName:  metrics-daemon-sa-token-2w9z8
    Optional:    false
QoS Class:       Burstable
Node-Selectors:  node-role.kubernetes.io/worker=
Tolerations:     
Events:
  Type     Reason                  Age                  From                                                Message
  ----     ------                  ----                 ----                                                -------
  Normal   Scheduled               32m                  default-scheduler                                   Successfully assigned openshift-multus/network-metrics-daemon-5hvqf to ip-10-0-55-138.us-east-2.compute.internal
  Warning  FailedCreatePodSandBox  32m (x3 over 32m)    kubelet, ip-10-0-55-138.us-east-2.compute.internal  Failed to create pod sandbox: open c:\k\etc\resolv.conf: The system cannot find the file specified.
  Normal   SandboxChanged          31m                  kubelet, ip-10-0-55-138.us-east-2.compute.internal  Pod sandbox changed, it will be killed and re-created.
  Warning  Failed                  31m (x3 over 31m)    kubelet, ip-10-0-55-138.us-east-2.compute.internal  Back-off pulling image "quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:985d38be2b84a7cd8088c4c9a0826c0eb14729137588ec3e748725b57994cd05"
  Normal   Pulling                 30m (x2 over 31m)    kubelet, ip-10-0-55-138.us-east-2.compute.internal  Pulling image "quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:b78fb952c0d054061ccf505cf18b099d6303d06d16cff4e12d24311e6e5be78a"
  Warning  Failed                  30m (x2 over 31m)    kubelet, ip-10-0-55-138.us-east-2.compute.internal  Failed to pull image "quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:b78fb952c0d054061ccf505cf18b099d6303d06d16cff4e12d24311e6e5be78a": rpc error: code = Unknown desc = Error response from daemon: unauthorized: access to the requested resource is not authorized
  Normal   Pulling                 30m (x2 over 31m)    kubelet, ip-10-0-55-138.us-east-2.compute.internal  Pulling image "quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:985d38be2b84a7cd8088c4c9a0826c0eb14729137588ec3e748725b57994cd05"
  Warning  Failed                  30m (x2 over 31m)    kubelet, ip-10-0-55-138.us-east-2.compute.internal  Failed to pull image "quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:985d38be2b84a7cd8088c4c9a0826c0eb14729137588ec3e748725b57994cd05": rpc error: code = Unknown desc = Error response from daemon: unauthorized: access to the requested resource is not authorized
  Warning  Failed                  73s (x132 over 31m)  kubelet, ip-10-0-55-138.us-east-2.compute.internal  Error: ImagePullBackOff


Actual results:
multus is trying to apply to Windows node

Expected results:
multus should not apply to Windows node

Additional info:

Comment 3 Anurag saxena 2020-07-15 15:24:24 UTC
*** Bug 1857241 has been marked as a duplicate of this bug. ***

Comment 4 gaoshang 2020-07-16 02:50:45 UTC
This bug has been fixed in OCP 4.6.0-0.nightly-2020-07-15-004428, thanks.

# oc describe node ip-10-0-184-164.us-east-2.compute.internal
...
Non-terminated Pods:          (0 in total)
  Namespace                   Name    CPU Requests  CPU Limits  Memory Requests  Memory Limits  AGE
  ---------                   ----    ------------  ----------  ---------------  -------------  ---
Allocated resources:

Comment 6 errata-xmlrpc 2020-10-27 16:13:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.