Bug 1856443 - usbip bind doesn't work
Summary: usbip bind doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: usbip
Version: 32
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jonathan Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-13 16:29 UTC by m-brueckner
Modified: 2021-02-18 21:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-18 21:11:16 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 208267 0 None None None 2020-07-19 21:12:26 UTC

Description m-brueckner 2020-07-13 16:29:54 UTC
Description of problem:

With the current version of Fedora 32 kernel usbip bind doesn't work and the command gives an error.

Version-Release number of selected component (if applicable):

Fedora Kernel 5.7.8-200
usbip-utils 2.0

How reproducible:
Always


Steps to Reproduce:
1. Load usbip kernel modules
modprobe usbip-core
modprobe usbip-host

2. Load usbipd
usbipd

3. bind an existing USB device
usbip bind -b 2-2


Actual results:
usbip: error: error binding device 2-2 to driver: No such device
usbip: error: could not bind device to usbip-host


Expected results:
USB device bound to usbip

Additional info:

Comment 1 Fedora Update System 2020-07-17 16:13:20 UTC
FEDORA-2020-286a37944e has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-286a37944e

Comment 2 Jonathan Dieter 2020-07-17 16:16:02 UTC
Just to be clear, I have not actually tested this build.  I just know that the usbip userspace can be somewhat coupled with the kernel, so hopefully a 5.7.x userspace will fix your problem.  If it doesn't, please let me know.

Comment 3 Fedora Update System 2020-07-18 01:18:19 UTC
FEDORA-2020-286a37944e has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-286a37944e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-286a37944e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 m-brueckner 2020-07-19 16:50:14 UTC
Sorry but it didn't work. Same error when binding.

Comment 5 Jonathan Dieter 2020-07-19 20:45:48 UTC
What's the output of "usbip list"?

Comment 6 m-brueckner 2020-07-19 21:00:08 UTC
I guess the command you want is 'usbip list -l'
The output on this machine (I don't have access to the one with the bind 2-2 at the moment) with Fedora 32 and your usbip testing version is:

[root@apc localuser]# usbip list -l
 - busid 3-1 (09fb:6001)
   Altera : Blaster (09fb:6001)

 - busid 3-2 (04b4:fd13)
   Cypress Semiconductor Corp. : Energenie EG-PMS (04b4:fd13)

 - busid 3-3 (0403:6001)
   Future Technology Devices International, Ltd : FT232 Serial (UART) IC (0403:6001)

 - busid 3-4 (04b4:fd13)
   Cypress Semiconductor Corp. : Energenie EG-PMS (04b4:fd13)

 - busid 1-1.2 (03fd:0008)
   Xilinx, Inc. : Platform Cable USB II (03fd:0008)

 - busid 1-1.4 (0403:6001)
   Future Technology Devices International, Ltd : FT232 Serial (UART) IC (0403:6001)

 - busid 2-1.6 (0bda:0129)
   Realtek Semiconductor Corp. : RTS5129 Card Reader Controller (0bda:0129)


No matter which device I choose to bind, the error is always the same:

[root@apc localuser]# usbip bind -b 3-1
usbip: error: error binding device 3-1 to driver: No such device
usbip: error: could not bind device to usbip-host

[root@apc localuser]# usbip bind -b 1-1.2
usbip: error: error binding device 1-1.2 to driver: No such device
usbip: error: could not bind device to usbip-host

Comment 7 Jonathan Dieter 2020-07-19 21:12:27 UTC
(In reply to m-brueckner from comment #6)
> I guess the command you want is 'usbip list -l'

Yep.  Thanks for picking that up. :)
 
> [root@apc localuser]# usbip bind -b 3-1
> usbip: error: error binding device 3-1 to driver: No such device
> usbip: error: could not bind device to usbip-host
> 
> [root@apc localuser]# usbip bind -b 1-1.2
> usbip: error: error binding device 1-1.2 to driver: No such device
> usbip: error: could not bind device to usbip-host

This looks like an upstream bug.
See https://bugzilla.kernel.org/show_bug.cgi?id=208267

Comment 8 Jonathan Dieter 2020-09-06 13:48:58 UTC
This is fixed in kernel-5.8.6 (in updates-testing): https://bodhi.fedoraproject.org/updates/FEDORA-2020-708b23f2ce
Please test and verify that it fixes your problem

Comment 9 Jonathan Dieter 2021-02-18 21:11:16 UTC
This should have been closed a while ago


Note You need to log in before you can comment on or make changes to this bug.