Bug 1856463 - Bump haproxy version to 2.0.16
Summary: Bump haproxy version to 2.0.16
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Andrew McDermott
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-13 17:36 UTC by Andrew McDermott
Modified: 2020-10-27 16:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:13:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:27 UTC

Description Andrew McDermott 2020-07-13 17:36:05 UTC
We need to stay current with latest point releases of haproxy-2.0 in OCP v4.

In 4.4 we are using 2.0.13
In 4.5 we are using 2.0.14

The goal here is to take 2.0.15 for 4.6 and stay current with upstream bug fixes and enhancements.

Comment 2 Andrew McDermott 2020-07-13 17:38:37 UTC
There is a corresponding PR that is soak testing haproxy-2.0.15 in CI:

  https://github.com/openshift/router/pull/148

Comment 4 Andrew McDermott 2020-07-28 11:10:31 UTC
Builds candidates:

- rhaos-4.6-rhel-7


https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=30363185

- rhaos-4.6-rhel-8

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=30363172

These just need verifying that the 2.0.16 RPMS are in a puddle:

http://download.eng.bos.redhat.com/rcm-guest/puddles/RHAOS/AtomicOpenShift/4.6/latest/x86_64/os/Packages/

And that the version of haproxy reports as 2.0.16 in a OCP installation.

e.g., 

$ oc rsh -n openshift-ingress router-<pod> haproxy -vv

Comment 5 Andrew McDermott 2020-07-29 08:54:43 UTC
I stood up a cluster this morning and see haproxy 2.0.16:

aim@spicy:~/clusters/4.6.0-0.ci-2020-07-29-045931

$ oc rsh -n openshift-ingress router-default-77bb794dbf-4c8sw rpm -q haproxy20
haproxy20-2.0.16-1.el7.x86_64

$ oc rsh -n openshift-ingress router-default-77bb794dbf-4c8sw haproxy -v
HA-Proxy version 2.0.16 2020/07/17 - https://haproxy.org/

Comment 9 Hongan Li 2020-08-05 02:39:13 UTC
Checked 4.6.0-0.nightly-2020-08-03-200401 and haproxy is updated to 2.0.16.

sh-4.2$ haproxy -v
HA-Proxy version 2.0.16 2020/07/17 - https://haproxy.org/

sh-4.2$ rpm -qa | grep haproxy
haproxy20-2.0.16-1.el7.x86_64

didn't find any issue so far and will move to verify when regression test is done.

Comment 10 Hongan Li 2020-08-07 04:26:01 UTC
no issue found during regression test, moving to verified

Comment 12 errata-xmlrpc 2020-10-27 16:13:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.