Bug 1856477 - Upgrade Helm form shows "Configure via:“ radio buttons are stacked when they should be on one line
Summary: Upgrade Helm form shows "Configure via:“ radio buttons are stacked when they ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Steve Goodwin
QA Contact: Jaivardhan Kumar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-13 18:12 UTC by David Taylor
Modified: 2020-10-27 16:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:13:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
Upgrade Helm with stacked radio-buttons (23.84 KB, image/png)
2020-07-13 18:12 UTC, David Taylor
no flags Details
Helm form showing radio buttons inline (127.59 KB, image/png)
2020-07-23 17:35 UTC, Steve Goodwin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5970 0 None closed Bug 1856477: Fix inline radio group after PF4 upgrade 2020-09-02 14:39:38 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:27 UTC

Description David Taylor 2020-07-13 18:12:53 UTC
Created attachment 1700880 [details]
Upgrade Helm with stacked radio-buttons

Description of problem:

After PFv4 upgrade, Helm => Upgrade Helm Release shows "Configure via:“ radio buttons are stacked when they  should be on one line.  See attached screenshot.



Version-Release number of selected component (if applicable):
4.6

How reproducible:

Always

Steps to Reproduce:
1. Goto Dev Console
2. Click on 'Helm' left-side nav item
3. Click on 'Upgrade' kabab menu for a listed Helm Release

Actual results:
radios are stacked

Expected results:
radios should be inline


Note:  /frontend/packages/dev-console/src/components/helm/form/HelmInstallUpgradeForm.tsx#L112 should include an 'inline' prop., at least one used to be defined here:  https://github.com/openshift/console/blob/fda898588f6a14107cf4a4e6c0897b615bde1667/frontend/packages/console-shared/src/components/formik-fields/SyncedEditorField.tsx#L102

Additional info:

Comment 3 Steve Goodwin 2020-07-23 17:32:38 UTC
Issue has been corrected. see screenshot

Comment 4 Steve Goodwin 2020-07-23 17:35:11 UTC
Created attachment 1702261 [details]
Helm form showing radio buttons inline

Comment 7 Jaivardhan Kumar 2020-09-03 12:17:55 UTC
Verified on Version: 4.6.0-0.nightly-2020-09-02-210353

Comment 9 errata-xmlrpc 2020-10-27 16:13:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.