Bug 1856583 - Alert Rules can't display correct according to order of 'Alerting State'
Summary: Alert Rules can't display correct according to order of 'Alerting State'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Andrew Pickering
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-14 02:17 UTC by hongyan li
Modified: 2020-10-27 16:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:14:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
Alert Rules order by 'Alerting State' (81.04 KB, image/png)
2020-07-14 02:17 UTC, hongyan li
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5957 0 None closed Bug 1856583: Monitoring: Fix table sort order for alert state and severity 2020-10-04 23:47:15 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:24 UTC

Description hongyan li 2020-07-14 02:17:22 UTC
Created attachment 1700927 [details]
Alert Rules order by 'Alerting State'

Description of problem:
Open console, go to Monitoring->Alerting, click tab Alert Rules
Order Alert Rules by 'Alerting State'


Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-13-203610

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
Alert Rule can't be ordered by state Firing and Silence state 

Expected results:
Alert Rule should be ordered by state Firing and Silence state 

Additional info:

Comment 3 hongyan li 2020-08-04 08:33:36 UTC
Test with payload 4.6.0-0.nightly-2020-08-03-200401
Alert Rules display correctly according to order of 'Alerting State'

Comment 5 errata-xmlrpc 2020-10-27 16:14:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.