Bug 1856593 - Sub-filter for one resource on Search page changes all other sub filters for the other resources
Summary: Sub-filter for one resource on Search page changes all other sub filters for ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Zac Herman
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-14 03:10 UTC by XiaochuanWang
Modified: 2020-10-27 16:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:14:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
bug recording (10.85 MB, video/quicktime)
2020-07-14 03:10 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6304 0 None closed Bug 1856593: Change from hideNameFilter flag to hideToolbar 2020-08-17 09:06:49 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:24 UTC

Description XiaochuanWang 2020-07-14 03:10:17 UTC
Created attachment 1700938 [details]
bug recording

Description of problem:
On Search page, choose different types of resources, input a search keyword in the top Name filter bar. Update/close one of the keyword in sub-filter, then the other sub filters are also changed. (see screen recording)

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-13-203610

How reproducible:
Always

Steps to Reproduce:
1. Go to Search page, choose different types of resources, such as:
(API)APIServer
(APIS)APIService
(CRD)CustomResourceDefinition
2. Choose the Name filter, input a keyword such as "console", then the below sub-filters for each resources are automatically set. This is correct
3. Update or close one of the sub-filters

Actual results:
3. The other sub-filters are also updated/closed

Expected results:
3. The other sub-filters should not be updated.

Additional info:

Comment 3 XiaochuanWang 2020-08-17 09:18:52 UTC
Sub filters are removed, filter on toolbar works for all sub resources.
Verified on 4.6.0-0.nightly-2020-08-16-072105

Comment 5 errata-xmlrpc 2020-10-27 16:14:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.