Bug 1856645 - Start time is same for initial two query though 1 minutes interval passed
Summary: Start time is same for initial two query though 1 minutes interval passed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Andrew Pickering
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-14 07:11 UTC by hongyan li
Modified: 2020-10-27 16:14 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:14:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6217 0 None closed Bug 1856645: Query Browser: Fix poller time range 2020-10-04 23:50:55 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:24 UTC

Description hongyan li 2020-07-14 07:11:54 UTC
Description of problem:
Login in cluster console as admin, click "Monitoring -> Metrics"
click 'insert example query'
Set query range as 15m
open the browser developer tools to watch the API request.
change refresh interval from refresh off to 1 minutes

API requests:
https://console-openshift-console.apps.qe-groupd-0714.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1594707753.643&end=1594708653.643&step=5&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s
https://console-openshift-console.apps.qe-groupd-0714.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1594707753.842&end=1594708653.842&step=5&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s
https://console-openshift-console.apps.qe-groupd-0714.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1594707813.848&end=1594708713.848&step=5&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s

[hongyli@hongyli-fed verification-tests]$ date --date='@1594707753.643'
Tue 14 Jul 2020 02:22:33 PM CST
[hongyli@hongyli-fed verification-tests]$ date --date='@1594707753.842'
Tue 14 Jul 2020 02:22:33 PM CST
[hongyli@hongyli-fed verification-tests]$ date --date='@1594707813.848'
Tue 14 Jul 2020 02:23:33 PM CST

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-13-203610

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
Start time is same for initial two query

Expected results:
The start time for second query should be 1 minutes later than the first query

Additional info:
Set query range as 5m
open the browser developer tools to watch the API request.
change refresh interval from refresh off to 1 minutes
https://console-openshift-console.apps.qe-groupd-0714.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1594708760.71&end=1594709060.71&step=5&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s
https://console-openshift-console.apps.qe-groupd-0714.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1594708760.941&end=1594709060.941&step=5&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s
https://console-openshift-console.apps.qe-groupd-0714.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1594708820.925&end=1594709120.925&step=5&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s

[hongyli@hongyli-fed verification-tests]$ date --date='@1594708760.71'
Tue 14 Jul 2020 02:39:20 PM CST
[hongyli@hongyli-fed verification-tests]$ date --date='@1594708760.941'
Tue 14 Jul 2020 02:39:20 PM CST
[hongyli@hongyli-fed verification-tests]$ date --date='@1594708820.925'
Tue 14 Jul 2020 02:40:20 PM CST

Set query range as 30m
open the browser developer tools to watch the API request.
change refresh interval from refresh off to 1 minutes
https://console-openshift-console.apps.qe-groupd-0714.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1594708439.784&end=1594710239.784&step=6&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s
https://console-openshift-console.apps.qe-groupd-0714.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1594708440.178&end=1594710240.178&step=6&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s
https://console-openshift-console.apps.qe-groupd-0714.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1594708500.015&end=1594710300.015&step=6&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s
[hongyli@hongyli-fed verification-tests]$ date --date='@1594708439.784'
Tue 14 Jul 2020 02:33:59 PM CST
[hongyli@hongyli-fed verification-tests]$ date --date='@1594708440.178'
Tue 14 Jul 2020 02:34:00 PM CST
[hongyli@hongyli-fed verification-tests]$ date --date='@1594708500.015'
Tue 14 Jul 2020 02:35:00 PM CST

Comment 4 hongyan li 2020-08-10 05:30:53 UTC
Test with payload 4.6.0-0.nightly-2020-08-07-202945

Login in cluster console as admin, click "Monitoring -> Metrics"
click 'insert example query'
Set query range as 15m
open the browser developer tools to watch the API request.
change refresh interval from refresh off to 1 minutes

API requests:
https://console-openshift-console.apps.hongyli-8-10.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1597034810.267&end=1597036610.267&step=6&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s
https://console-openshift-console.apps.hongyli-8-10.qe.devcluster.openshift.com/api/prometheus/api/v1/query_range?start=1597034870.273&end=1597036670.273&step=6&query=sort_desc%28sum%28sum_over_time%28ALERTS%7Balertstate%3D%22firing%22%7D%5B24h%5D%29%29+by+%28alertname%29%29&timeout=5s

date --date='@1597034810.267'
Mon 10 Aug 2020 12:46:50 PM CST
date --date='@1597034870.273'
Mon 10 Aug 2020 12:47:50 PM CST

time is correct for initial 2 queries.

Comment 6 errata-xmlrpc 2020-10-27 16:14:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.