Bug 1856667 - All doc links on OCP 4.6 cluster should point to 4.6 not 4.5 [NEEDINFO]
Summary: All doc links on OCP 4.6 cluster should point to 4.6 not 4.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-14 07:50 UTC by XiaochuanWang
Modified: 2020-10-27 16:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:14:10 UTC
Target Upstream Version:
xiaocwan: needinfo? (jhadvig)


Attachments (Terms of Use)
bug screenshot (165.51 KB, image/png)
2020-07-14 07:50 UTC, XiaochuanWang
no flags Details
Failed to reproduce (165.51 KB, image/png)
2020-07-14 10:36 UTC, Jakub Hadvig
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console-operator pull 454 0 None closed Bug 1856667: Bump DEFAULT_DOC_URL for okd & ocp 2020-11-11 06:29:48 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:24 UTC

Description XiaochuanWang 2020-07-14 07:50:32 UTC
Created attachment 1700977 [details]
bug screenshot

Description of problem:
On Dev console, check Project Access tab page. The base url in helper doc link is still using previous version (4.5)

Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-13-203610

How reproducible:
Always

Steps to Reproduce:
1. Go to Dev console
2. Go to Project -> choose one project -> Project Access tab page
3. Check the base url in helper doc link.

Actual results:
openshiftHelpBase on current version (4.6) is still link to OCP 4.5 doc

Expected results:
Should link to current doc version: https://docs.openshift.com/container-platform/4.6/authentication/using-rbac.html

Additional info:

Comment 1 Jakub Hadvig 2020-07-14 10:36:00 UTC
Created attachment 1701004 [details]
Failed to reproduce

Tried to reproduce on 4.6.0-0.ci-2020-07-14-002831 cluster, but the docs link was pointing to the latest docs.

Comment 4 Yanping Zhang 2020-08-07 06:05:34 UTC
Checked on OCP 4.6 cluster again, all doc links on OCP 4.6 cluster direct to 4.5, it should be fixed from console side. 
Move back to "Management Console" component.

Comment 5 Yanping Zhang 2020-08-07 06:17:23 UTC
On OCP 4.6 cluster, ”documentationBaseURL“ is still "https://docs.openshift.com/container-platform/4.5/", need update to 4.6.

Comment 8 XiaochuanWang 2020-08-12 02:34:15 UTC
Verified on 4.6.0-0.nightly-2020-08-11-194853
Doc link is up to: https://docs.openshift.com/container-platform/4.6/authentication/using-rbac.html

Comment 10 errata-xmlrpc 2020-10-27 16:14:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.