Bug 1856675 - Filter display and Alerts display are inconsistent when change tab
Summary: Filter display and Alerts display are inconsistent when change tab
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Andrew Pickering
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-14 08:17 UTC by hongyan li
Modified: 2020-10-27 16:14 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:14:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
label filter and alert display are inconsistent (44.40 KB, image/png)
2020-07-14 08:19 UTC, hongyan li
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6187 0 None closed Bug 1856675: Fix filter toolbar initialization from URL parameters 2020-10-04 23:47:16 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:52 UTC

Description hongyan li 2020-07-14 08:17:32 UTC
Description of problem:
From cluser console-Monitoring-Alerting page
From dropdown of name, choose Label and input "alertname=Watchdog" then choose the same from suggestion line
only Alert Watchdog displays
Click tab Silence, then click tab Alert
Still only Watchdog displays, but label filter is not there


Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-07-13-203610

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
Filter display and Alerts display are inconsistent

Expected results:
Filter display and Alerts display should be consistent


Additional info:

Comment 1 hongyan li 2020-07-14 08:19:00 UTC
Created attachment 1700979 [details]
label filter and alert display are inconsistent

Comment 5 hongyan li 2020-08-04 06:11:01 UTC
Issue still exists in label
4.6.0-0.nightly-2020-08-03-200401

Comment 6 hongyan li 2020-08-05 01:34:25 UTC
Test with payload 4.6.0-0.nightly-2020-08-04-193041

Filter display and Alerts display are consistent now

Comment 8 errata-xmlrpc 2020-10-27 16:14:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.