Bug 1856965 - The tripleo_ceph_uuid role should support the ceph_ansible_limit option
Summary: The tripleo_ceph_uuid role should support the ceph_ansible_limit option
Keywords:
Status: CLOSED DUPLICATE of bug 1855112
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: tripleo-ansible
Version: 16.1 (Train)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: John Fulton
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-14 19:36 UTC by John Fulton
Modified: 2020-08-14 19:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-14 19:42:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1887579 0 None None None 2020-07-14 21:28:12 UTC
OpenStack gerrit 741059 0 None ABANDONED [WIP] Pass ceph_ansible_limit to UUID and remote_tmp playbooks 2021-02-19 13:25:03 UTC

Description John Fulton 2020-07-14 19:36:08 UTC
While using -e ceph_ansible_limit to exclude nodes the task gather uuid task [0] still runs on all nodes. 

This can affect deployments at scale when a couple of nodes are offline because the operator won't be able to exclude them using ansible's --limit feature.

The problem is that the ceph_ansible_limit is getting passed to the ceph-ansible run but not to the nodes-uuid run [2]. 

Pasting line 55 of [1] into line 32 of [2] should give you a quick workaround.

[0] https://github.com/openstack/tripleo-ansible/blob/ca165ec94018293dfbbbd37c44a2704b8144f203/tripleo_ansible/roles/tripleo_ceph_uuid/tasks/gather.yml#L17 

[1] https://github.com/openstack/tripleo-ansible/blob/stable/train/tripleo_ansible/roles/tripleo-ceph-run-ansible/tasks/main.yml#L55
[2] https://github.com/openstack/tripleo-ansible/blob/ca165ec94018293dfbbbd37c44a2704b8144f203/tripleo_ansible/roles/tripleo_ceph_uuid/tasks/gather.yml#L17

Comment 1 John Fulton 2020-08-14 19:42:57 UTC

*** This bug has been marked as a duplicate of bug 1855112 ***


Note You need to log in before you can comment on or make changes to this bug.