Bug 1857188 - [OSP][IPI] Delete process loops when it cannot delete swift container
Summary: [OSP][IPI] Delete process loops when it cannot delete swift container
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Mike Fedosin
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-15 11:24 UTC by David Sanz
Modified: 2020-10-27 16:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:14:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3893 0 None closed Bug 1857188: OpenStack: skip container deletion if it was removed 2020-10-01 08:10:25 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:14:57 UTC

Description David Sanz 2020-07-15 11:24:53 UTC
Description of problem:

Deleting process enter on a loop if it cannot delete a swift container:

12:27:18  level=debug msg="Deleting openstack containers"
12:27:18  level=error msg="Resource not found"
12:27:18  level=debug msg="Exiting deleting openstack containers"
12:28:14  level=debug msg="Deleting openstack containers"
12:28:14  level=error msg="Resource not found"
12:28:14  level=debug msg="Exiting deleting openstack containers"
12:29:23  level=debug msg="Deleting openstack containers"
12:29:23  level=error msg="Resource not found"
12:29:23  level=debug msg="Exiting deleting openstack containers"
12:30:59  level=debug msg="Deleting openstack containers"
12:30:59  level=error msg="Resource not found"
12:30:59  level=debug msg="Exiting deleting openstack containers"
12:33:06  level=debug msg="Deleting openstack containers"
12:33:06  level=error msg="Resource not found"
12:33:06  level=debug msg="Exiting deleting openstack containers"
12:35:42  level=debug msg="Deleting openstack containers"
12:35:42  level=error msg="Resource not found"
12:35:42  level=debug msg="Exiting deleting openstack containers"
12:39:06  level=debug msg="Deleting openstack containers"
12:39:06  level=error msg="Resource not found"
12:39:06  level=debug msg="Exiting deleting openstack containers"
12:43:42  level=debug msg="Deleting openstack containers"
12:43:42  level=error msg="Resource not found"
12:43:42  level=debug msg="Exiting deleting openstack containers"

Version-Release number of the following components:


How reproducible:

Steps to Reproduce:
1.Install IPI on OSP
2.Delete cluster
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 4 David Sanz 2020-07-16 13:43:25 UTC
Verified on 4.6.0-0.nightly-2020-07-16-122837

15:40:53  level=debug msg="Deleting openstack containers"
15:40:53  level=debug msg="Bulk deleting container \"mrnd-13-46-tr5d9-image-registry-humxdbmmtsuyytmtuaqvmfujgykcjx\" objects"
15:40:53  level=debug msg="Deleting container \"mrnd-13-46-tr5d9-image-registry-humxdbmmtsuyytmtuaqvmfujgykcjx\""
15:40:53  level=debug msg="Deleting Subnet: \"6ea52512-e24a-4f2e-9e8f-10533eeb8f6e\""
15:40:53  level=debug msg="Bulk deleting container \"mrnd-13-46-tr5d9-image-registry-unlphvsetcbelwdbpaevmqcgpevows\" objects"
15:40:53  level=debug msg="Deleting container \"mrnd-13-46-tr5d9-image-registry-unlphvsetcbelwdbpaevmqcgpevows\""
15:40:54  level=debug msg="Exiting deleting openstack containers"
15:40:54  level=debug msg="goroutine deleteContainers complete"

Comment 6 errata-xmlrpc 2020-10-27 16:14:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.