Bug 1857310 - Accessibility: Current line number doesn't have enough contrast in YAML editor
Summary: Accessibility: Current line number doesn't have enough contrast in YAML editor
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.6.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-15 16:19 UTC by Samuel Padgett
Modified: 2020-10-27 16:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.6.0-0.ci-2020-07-15-072223 Cluster ID: 6a33ed20-dc8b-43aa-a7e1-731adea40ba9 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:79.0) Gecko/20100101 Firefox/79.0
Last Closed: 2020-10-27 16:14:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
YAML editor (80.02 KB, image/png)
2020-07-15 16:19 UTC, Samuel Padgett
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6001 0 None closed Bug 1857310: Give current line number more contrast in YAML editor 2020-07-29 06:24:30 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:15:04 UTC

Description Samuel Padgett 2020-07-15 16:19:48 UTC
Created attachment 1701258 [details]
YAML editor

See screenshot. The line number for the current line in the YAML editor clearly doesn't have enough contrast to meet accessibility requirements. This might be a regression after the recent Patternfly update.

Comment 3 Yanping Zhang 2020-07-29 07:13:52 UTC
Checked on OCP 4.6 cluster with payload 4.6.0-0.nightly-2020-07-25-091217
On yaml edit page, the current line number is white on dark gray.
The bug is fixed.

Comment 5 errata-xmlrpc 2020-10-27 16:14:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.