Bug 1857317 - [v2v][UI][RHV to CNV VM import] Imported VMs Disk view cannot be displayed.
Summary: [v2v][UI][RHV to CNV VM import] Imported VMs Disk view cannot be displayed.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Phillip Bailey
QA Contact: Md Nadeem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-15 16:36 UTC by Ilanit Stein
Modified: 2020-10-27 16:15 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:14:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
disks_view_screenshot (126.75 KB, image/png)
2020-07-15 16:36 UTC, Ilanit Stein
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5690 0 None closed Bug 1845189: Fix NPE in combinedDisk 2020-11-10 11:40:55 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:15:04 UTC

Description Ilanit Stein 2020-07-15 16:36:55 UTC
Created attachment 1701275 [details]
disks_view_screenshot

Description of problem:
This issue occurred so far once on a Bare metal CNV environment.
We haven't seen it on PSI environments on which we worked so far.

After importing successfully 2 VMs from 2 different RHV environments to CNV,
Entering the VMs Disks view is not displayed.

For VMs that were created on this BM env, from various OS types, there is no problem with viewing their disks.

Messages displayed in the Disks view (screen shot also attached):
Oh no! Something went wrong.

TypeError
Description:
Cannot read property 'some' of undefined
Component Trace:
in ListPageWrapper_
    in Unknown
    in Unknown
    in w
    in O
    in w
    in div
    in w
    in w
    in w
    in MultiListPage
    in M
    in Unknown
    in Unknown
    in w
    in O
    in w
    in w
    in t
    in t
    in div
    in Data
    in StatusBox
    in div
    in Unknown
    in Unknown
    in Unknown
    in Unknown
    in w
    in O
    in w
    in Unknown
    in s
    in DetailsPage
    in j
    in c
    in t
    in R
    in t
    in div
    in div
    in section
    in d
    in Unknown
    in w
    in w
    in div
    in div
    in f
    in p
    in div
    in p
    in NotificationDrawer
    in Unknown
    in w
    in main
    in div
    in b
    in component
    in t
    in t
    in t
    in t

Stack Trace:

TypeError: Cannot read property 'some' of undefined
    at https://console-openshift-console.apps.cnvcl2.lab.eng.tlv2.redhat.com/static/kubevirt-chunk-b47cb06750857a66982b.min.js:1:49322
    at Array.find (<anonymous>)
    at https://console-openshift-console.apps.cnvcl2.lab.eng.tlv2.redhat.com/static/kubevirt-chunk-b47cb06750857a66982b.min.js:1:49283
    at Array.map (<anonymous>)
    at j.getCombinedDisks (https://console-openshift-console.apps.cnvcl2.lab.eng.tlv2.redhat.com/static/kubevirt-chunk-b47cb06750857a66982b.min.js:1:49099)
    at https://console-openshift-console.apps.cnvcl2.lab.eng.tlv2.redhat.com/static/kubevirt-chunk-b47cb06750857a66982b.min.js:1:165849
    at flatten (https://console-openshift-console.apps.cnvcl2.lab.eng.tlv2.redhat.com/static/kubevirt-chunk-b47cb06750857a66982b.min.js:1:166073)
    at N.render (https://console-openshift-console.apps.cnvcl2.lab.eng.tlv2.redhat.com/static/main-chunk-13011ba3763fbdcc662b.min.js:1:775772)
    at va (https://console-openshift-console.apps.cnvcl2.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:65523)
    at ma (https://console-openshift-console.apps.cnvcl2.lab.eng.tlv2.redhat.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:65318)

Version-Release number of selected component (if applicable):
CNV-2.4 from July 12 2020.

Comment 1 Ilanit Stein 2020-07-16 11:36:46 UTC
I tested it on another bare metal with CNV-2.4 latest, and the issue did not reproduce.
Same here, there were RHEL7 VM imports using Ceph/NFS.
I tried 10 VM imports from RHV to CNV.

Comment 2 Yaacov Zamir 2020-07-20 04:31:45 UTC
@Ilanit hi,

If we can't reproduce, should we close this and re-open if we see it again and can reproduce ?

Comment 3 Ilanit Stein 2020-07-25 18:41:57 UTC
@Yaacov,

I hope that based on the information provided, it might be that the cause can be found.
If this is not the case, then yes, bug can be closed from my end.

Comment 4 Yaacov Zamir 2020-07-26 09:23:50 UTC
Thanks, we will try to look into the causes.

Comment 5 chhu 2020-07-29 04:20:53 UTC
Hit the same error message in my test scenario, please see more details as below:
--------------------------------------------------------------------------------------
Description of problem:
  Create a VM Template, try to see it's disks in web console,
  Hit TypeEror: "Cannot read property 'some' of undefined"

Version-Release number of selected component (if applicable):
  container-native-virtualization-hco-bundle-registry:v2.3.0-472

How reproducible:
  100%

Steps to Reproduce:
1. Login to the webconsole, in Project: openshift-cnv,
   Click Workloads: "Virtualization" -> "Virtual Machine Templates", click "Create Virtual Machine Template", Input:
   Name: vmt, Source: URL, URL: http://s3-qe-cn-storage.usersys.redhat.com/libvirt-CI-resources/RHEL-8.2-x86_64-latest.qcow2
   Operating System: RedHat Enterprise Linux 8 or higher, Flavor: Custom, Memory: 2 GiB, CPUs: 2, Workload Profile: server
   Click Next, use default Networking,
   Click Next, Storage: Source URL, URL: http://s3-qe-cn-storage.usersys.redhat.com/libvirt-CI-resources/RHEL-8.2-x86_64-latest.qcow2,
   Name: rootdisk, Size:12 GiB, Interface: VirtIO, Volume Mode: Filesystem, Access Mode: RWX
   Click Save.

2. Check the PVC: vmt-rootdisk is created

3. Create the PV:
#cat pv-nfs-rhel.yaml
---
apiVersion: v1
kind: PersistentVolume
metadata:
  name: pv-nfs-rhel-d3
  labels:
    kubevirt.io: ""
    os: "rhel"
spec:
  capacity:
    storage: 12Gi
  accessModes:
    - ReadWriteMany
  nfs:
    server: intel-***.englab.nay.redhat.com
    path: /home/nfs/disk2
#oc create -f pv-nfs-rhel.yaml

4. Check the PV is created, and Bound to PVC vmt-rootdisk, dv with Successded phase.
   #oc get pv
   NAME             CAPACITY   ACCESS MODES   RECLAIM POLICY   STATUS        CLAIM                           STORAGECLASS   REASON   AGE
   pv-nfs-rhel-d3   12Gi       RWX            Retain           Bound         openshift-cnv/vmt-rootdisk                              51m

   #oc get pvc
   NAME              STATUS        VOLUME           CAPACITY   ACCESS MODES   STORAGECLASS   AGE
   vmt-rootdisk      Bound         pv-nfs-rhel-d3   12Gi       RWX                           52m

   # oc get dv
   NAME           PHASE             PROGRESS   RESTARTS   AGE
   vmt-rootdisk   Succeeded         100.0%     0          64m

5. Select the VM Template, Click "Disks", hit TypeEror: "Cannot read property 'some' of undefined"

  Stack Trace:
--------------------------------------------------------------------------------
TypeError: Cannot read property 'some' of undefined
    at https://console-openshift-console.apps.virtcnv.qe.devcluster.openshift.com/static/kubevirt-chunk-1d996ce4afc41bb43bcd.min.js:1:49322
    at Array.find (<anonymous>)
    at https://console-openshift-console.apps.virtcnv.qe.devcluster.openshift.com/static/kubevirt-chunk-1d996ce4afc41bb43bcd.min.js:1:49283
    at Array.map (<anonymous>)
    at j.getCombinedDisks (https://console-openshift-console.apps.virtcnv.qe.devcluster.openshift.com/static/kubevirt-chunk-1d996ce4afc41bb43bcd.min.js:1:49099)
    at https://console-openshift-console.apps.virtcnv.qe.devcluster.openshift.com/static/kubevirt-create-vm-wizard-chunk-8a6935f6ce52d5f3e317.min.js:1:129720
    at flatten (https://console-openshift-console.apps.virtcnv.qe.devcluster.openshift.com/static/kubevirt-create-vm-wizard-chunk-8a6935f6ce52d5f3e317.min.js:1:129944)
    at N.render (https://console-openshift-console.apps.virtcnv.qe.devcluster.openshift.com/static/main-chunk-417f9574d1da08c85e1f.min.js:1:775772)
    at va (https://console-openshift-console.apps.virtcnv.qe.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:65523)
    at ma (https://console-openshift-console.apps.virtcnv.qe.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:65318)
--------------------------------------------------------------------------------

Actual results:
  In step5, the disk is not listed

Expected results:
  In step5, show the disk

Additional info:
  Create VM from the VM Template, Click the VM Disks in webpage, hit the same error, but can start the VM and login to the VM console, touch file in VM.
  #oc get dv
  NAME           PHASE       PROGRESS   RESTARTS   AGE
  vm-rootdisk    Succeeded   100.0%     0          16m  -> VM root disk
  vmt-rootdisk   Succeeded   100.0%     0          76m  -> VM Template root disk

Comment 9 Ilanit Stein 2020-09-24 15:29:22 UTC
@Phillip,

What should be the verification steps please?

Comment 10 Phillip Bailey 2020-09-28 13:34:53 UTC
@Ilanit,

I didn't work on this bug directly. It looks like a PR I submitted previously fixed the cause of this bug, but I'll try to answer your question as best as I can.

From my understanding of your description of this bug, the problem presents intermittently only on BM environments after importing VMs from RHV to CNV. I assume, and please correct me if I'm misunderstanding the situation, that you're asking for verification steps because you can't get a proper environment for testing and/or the problem is difficult to reproduce. If that's the case, I recommend using the scenario from the bug my PR was meant to address, https://bugzilla.redhat.com/show_bug.cgi?id=1845189.

That problem appears to be similar to the one that Chenli was dealing with in comment 5, and presented if two conditions were true: 

1. A PV/PVC was created in a given namespace using a method outside of the kubevirt console plugin, such as from the CLI or the console PVC wizard
2. A VM template was created in the same namespace

For this issue, you can either use the verification steps that Chenli posted above or the steps from comment 1 in https://bugzilla.redhat.com/show_bug.cgi?id=1845189.

Please let me know if this doesn't adequately address your question.

Comment 11 Md Nadeem 2020-09-30 14:38:15 UTC
Thanks @Phillip Bailey 

The BZ has verified by following steps : https://bugzilla.redhat.com/show_bug.cgi?id=1857317#c5

on OpenShift Version 4.6.0-fc.8.

Comment 13 errata-xmlrpc 2020-10-27 16:14:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.