Bug 1857359 - large capsule syncs cause slow processing of dynflow tasks/steps
Summary: large capsule syncs cause slow processing of dynflow tasks/steps
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Capsule - Content
Version: 6.7.0
Hardware: All
OS: All
high
unspecified vote
Target Milestone: 6.7.2
Assignee: Justin Sherrill
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-15 17:26 UTC by Mike McCune
Modified: 2020-10-27 13:25 UTC (History)
16 users (show)

Fixed In Version: tfm-rubygem-katello-3.14.0.25-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1853076
Environment:
Last Closed: 2020-07-30 20:21:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 30286 0 Normal Closed large capsule syncs cause slow processing of dynflow tasks/steps 2021-02-10 05:22:49 UTC
Red Hat Product Errata RHBA-2020:3255 0 None None None 2020-07-30 20:21:21 UTC

Comment 2 Bryan Kearney 2020-07-15 20:05:25 UTC
Moving this bug to POST for triage into Satellite since the upstream issue https://projects.theforeman.org/issues/30286 has been resolved.

Comment 5 Lukáš Hellebrandt 2020-07-28 12:39:00 UTC
Verified with Sat 6.7.2 snap 2.0.

This is hard to verify as there is no real reproducer nor is it concretely specified how this bug actually manifests. I had a Satellite, an external Capsule and a Host registered through that Capsule. I tried to cause huge sync load on both Satellite and Capsule. During this time, I tried to also run different tasks on the hosts, e.g. ran a command through remote execution. I measured systems load which was high due to ~25 repos being synced at a time but nothing was unusually or unexpectably slow. Most CPU time was taken by pulp workers which is expected when syncing. I haven't noticed any files growing too much (cache grew a few GBs and shrinked after the operation) or lowered responsibility at any time. The remote commands have been ran correctly and almost immediately. Dynflow log looks ok. To conclude, I haven't noticed any issues while doing a large Capsule sync.

Comment 7 errata-xmlrpc 2020-07-30 20:21:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3255


Note You need to log in before you can comment on or make changes to this bug.