Bug 185744 - Serial console input does not work in dom0
Summary: Serial console input does not work in dom0
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: James Morris
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 179599
TreeView+ depends on / blocked
 
Reported: 2006-03-17 15:21 UTC by James Morris
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-02 04:14:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Morris 2006-03-17 15:21:18 UTC
Serial console works, but is ouput only.

Comment 1 James Morris 2006-03-17 21:34:13 UTC
Looks like it's being caused or triggered by ACPI PNP.  As a temporary
workaround, use pnpacpi=off on the kernel command line (unless you actually need
it, of course).

Comment 2 Stephen Tweedie 2006-03-17 21:56:38 UTC
Nice catch --- with pnpacpi=off, I can run a xen0 kernel and still capture
serial console from another box.

Comment 3 James Morris 2006-03-17 22:51:19 UTC
I've reproduced this problem in xen-unstable, so it looks like an upstream bug.

Comment 4 James Morris 2006-06-02 04:14:08 UTC
This should have been resolved with the upstream fix.


Note You need to log in before you can comment on or make changes to this bug.