Bug 185748 - F-spot doesn't start
F-spot doesn't start
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-17 10:54 EST by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 13:18:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2006-03-17 10:54:50 EST
Description of problem:
I get this trace on the console:

Unhandled Exception: Mono.Data.SqliteClient.SqliteSyntaxException: file is
encrypted or is not a database
in <0x00106> Mono.Data.SqliteClient.SqliteCommand:GetNextStatement (IntPtr
pzStart, System.IntPtr pzTail, System.IntPtr pStmt)
in <0x000d0> Mono.Data.SqliteClient.SqliteCommand:ExecuteReader (CommandBehavior
behavior, Boolean want_results, System.Int32 rows_affected)
in <0x0001c> Mono.Data.SqliteClient.SqliteCommand:ExecuteNonQuery ()
in <0x0004c> MetaStore:CreateTable ()
in <0x000a9> MetaStore:.ctor (Mono.Data.SqliteClient.SqliteConnection
connection, Boolean is_new)
in <0x000c7> Db:Init (System.String path, Boolean create_if_missing)
in <0x0008d> FSpot.Core:.ctor ()
in <0x00337> FSpot.Driver:Main (System.String[] args)

This is the latest rawhide snapshot.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Christopher Aillon 2006-03-17 11:05:36 EST
This is a database incompatibility.  What is the output of:

% file ~/.gnome2/f-spot/photos.db
Comment 2 Kjartan Maraas 2006-03-18 08:03:06 EST
Ok, the file is a sqlite 2.1 database so I'm guessing that I'm just being bit by
the fact that f-spot moved to sqlite 3 during this development cycle. Are there
tools to convert the database in sqlite3?
Comment 3 Christopher Aillon 2006-10-31 13:18:53 EST
Sorry for the delay.  Don't think there were any tools per se, but I think there
was a way to dump out and then re-import.  Anyway, going to mark as CANTFIX
since not much that can be done.

Note You need to log in before you can comment on or make changes to this bug.