Bug 185749 - Package Updater can't resolve dependencies
Package Updater can't resolve dependencies
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-17 11:11 EST by Evert Verhellen
Modified: 2015-08-22 12:33 EDT (History)
0 users

See Also:
Fixed In Version: 3.10.6-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-12 14:07:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evert Verhellen 2006-03-17 11:11:15 EST
Package Updater says the following updates are available:

[X] Updated gnome-python2-desktop packages available
[X] Updated gnome-python2-extras packages available
[X] Updated gnome-python2 packages available

Clicking "Apply updates" will result in a dialog "Error resolving dependencies"
with the following details:

Missing Dependency: gnome-python2-extras = 2.13.3-3.2 is needed by package
gnome-python2-gtkhtml2
Missing Dependency: gnome-python2 = 2.12.3-1.2 is needed by package
gnome-python2-canvas
Missing Dependency: gnome-python2-desktop = 2.13.3-1.1 is needed by package
gnome-python2-gnomeprint

I think this is because there are currently multiple versions installed of the
"consumer" packages:

gnome-python2-canvas-2.12.3-1.2
gnome-python2-canvas-2.12.4-1
gnome-python2-gnomeprint-2.13.3-1.1
gnome-python2-gnomeprint-2.14.0-1
gnome-python2-gtkhtml2-2.13.3-3.2
gnome-python2-gtkhtml2-2.14.0-1

This happened during a previous Package Updater session. After the newer
packages were installed (I think) but before the older packages were completely
removed I triggered a system "crash" (that is I just powered off the VMware
virtual machine).

After that there appears to be no obvious way to get Package Updater going
again. Uninstalling the older packages works but isn't something the average
person will do I guess. Major bug?

Steps to reproduce:
 1. Install Fedora Core 5 Test 3.
 2. Start Package Updater.
 3. Power off system during update process.
 4. Restart system.
 5. Start update process again.

Version details:
pirut-0.9.10-1
pirut-1.0.1-1

It appears there were also 2 pirut packages installed so Package Updater doesn't
properly clean-up obsolete stuff. Should that be considered a separate bug?
Comment 1 Jeremy Katz 2006-04-12 14:07:25 EDT
There were some cases during the test release cycle at which selinux caused
updates to end up in this case.  That is basically a "shouldn't happen" case and
there's not much that we can really do in the package updater to work around it :( 
Comment 2 Fedora Update System 2015-06-15 22:12:36 EDT
pcp-3.10.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/pcp-3.10.5-1.fc22
Comment 3 Fedora Update System 2015-06-15 22:13:48 EDT
pcp-3.10.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pcp-3.10.5-1.fc21
Comment 4 Fedora Update System 2015-06-15 22:14:35 EDT
pcp-3.10.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pcp-3.10.5-1.fc20
Comment 5 Fedora Update System 2015-06-15 22:16:43 EDT
pcp-3.10.5-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/pcp-3.10.5-1.el5
Comment 6 Fedora Update System 2015-08-04 01:37:52 EDT
pcp-3.10.6-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/pcp-3.10.6-1.fc22
Comment 7 Fedora Update System 2015-08-04 01:38:34 EDT
pcp-3.10.6-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pcp-3.10.6-1.fc21
Comment 8 Fedora Update System 2015-08-04 01:39:11 EDT
pcp-3.10.6-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/pcp-3.10.6-1.el5
Comment 9 Fedora Update System 2015-08-13 12:57:09 EDT
pcp-3.10.6-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2015-08-13 12:58:45 EDT
pcp-3.10.6-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-08-22 12:33:36 EDT
pcp-3.10.6-1.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.