Bug 185757 - Yum memory increasing until freezing system with CPU at 100%
Summary: Yum memory increasing until freezing system with CPU at 100%
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-17 17:13 UTC by Julien Tane
Modified: 2014-01-21 22:53 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-04-19 20:40:44 UTC


Attachments (Terms of Use)

Description Julien Tane 2006-03-17 17:13:18 UTC
Description of problem:

When I try to do a "yum list updates" as root 

Yum starts:

Setting up repositories
development               100% |=========================| 1.1 kB    00:00
livna-stable              100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
updates-released          100% |=========================|  951 B    00:00
pyvault                   100% |=========================|  951 B    00:00
CRAN                      100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.2 MB    00:04

But here it just consumes more memory and memory with 100% CPU.
If I don't stop it it just freezes my system.


Version-Release number of selected component (if applicable):

yum-2.4.1-1.fc4


How reproducible:
every time

Steps to Reproduce:
1. log under root and cd into empty dir a
2. run "yum list updates"
3. yum displays logs as described above
4. kill yum before it's too late :-(
  
Actual results:

Need to kill Yum!!!!! And can't update the system.

Expected results:

It should give the list op packages to be updated.

Additional info:
I updated squid and sqllite a few days ago... If I remember well.
And other thing but I don't think I updated yum the day before it 
started.

Comment 1 Julien Tane 2006-03-17 17:32:38 UTC
the python sqllite package is:
python-sqlite-1.1.6-1
and sqllite is:
sqlite-3.3.3-1.2


Comment 2 Seth Vidal 2006-03-17 18:07:16 UTC
where did you get the sqlite pkg from?

It didn't come in FC4 that I can see.


Comment 3 Julien Tane 2006-03-17 18:29:13 UTC
I don't know I am not sure. I have to see whether I can get this info from the
log files but here the relevant info from rpm -qi sqlite

Vendor: Red Hat, Inc.
Build Date: Sun 12 Feb 2006 10:39:28 CET
Build Date: sqlite-3.3.3-1.2.src.rpm
Build Host: hs20-bc1-4.build.redhat.com
Install Date: Thu 16 Mar 2006 13:54:52 CET   
Signature   : DSA/SHA1, Tue 07 Mar 2006 00:45:46 CET, Key ID b44269d04f2a6fd2



Comment 4 Seth Vidal 2006-03-17 18:30:44 UTC
that appears to have been pulled out of rawhide.



Comment 5 Julien Tane 2006-03-17 18:51:34 UTC
It is possible and even probable. Sorry if you think it is not relevant.
I could have waited for a new version of yum and try ( that is 
uninstall sqlite and yum and redo things). I thought it would be better if you
knew. My understanding is that the development branch is still relevant.
Or it is not when the diverse fedora tests are out there ?

N.B: the version installed has:
Signature   : DSA/SHA1, Tue 07 Mar 2006 00:45:46 CET, Key ID b44269d04f2a6fd2
and the fedora 4.92:
Signature   : DSA/SHA1, Tue 14 Feb 2006 22:20:44 CET, Key ID da84cbd430c9ecf8

The rest apart from that is exacltly the same: even the size.






Comment 6 Julien Tane 2006-03-20 16:55:55 UTC
Problem solved (probably due to  python24-sqlite!!! my fault!!!!!)

Well I installed the yum rpm from fedora Core 5.  It still did not work.
The package sqlite I had on my computer seemed the same as the one in rawhide
and now also the same as in fedora 5. 

I downloaded python-sqlite from Fedora 5 and did 
rpm -U python-sqlite-1.1.7-1.2.i386.rpm 

Clash with python24-sqlite ( which I thought I had remove a few month ago.
I guess I had not cleaned the python24 packages well enough).

so I removed "python24-sqlite" with 

rpm -e python24-sqlite

And updated:
 rpm -U python-sqlite-1.1.7-1.2.i386.rpm

and now everything seems to work fine. Sorry for the trouble!


Note You need to log in before you can comment on or make changes to this bug.