Bug 1857805 (CVE-2020-14332) - CVE-2020-14332 Ansible: module_args does not censor properly in --check mode
Summary: CVE-2020-14332 Ansible: module_args does not censor properly in --check mode
Keywords:
Status: VERIFIED
Alias: CVE-2020-14332
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1857808 1859535 1857817 1857818 1859485 1867905 1867906 1874346 1874348 1874350
Blocks: 1856460
TreeView+ depends on / blocked
 
Reported: 2020-07-16 15:29 UTC by Borja Tarraso
Modified: 2021-07-09 17:20 UTC (History)
25 users (show)

Fixed In Version: ansible-engine 2.9.12, ansible-engine 2.8.14
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the Ansible Engine when using module_args. Tasks executed with check mode (--check-mode) do not properly neutralize sensitive data exposed in the event data. This flaw allows unauthorized users to read this data. The highest threat from this vulnerability is to confidentiality.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Borja Tarraso 2020-07-16 15:29:59 UTC
module_args is not censored properly when using the check mode. This only happens using -vvv on the CLI, but in AWX/Tower it does not matter what verbosity setting is used, because it is saved in the event data regardless. So sensitive data is exposed allowing unauthorized users accessing to it.

Comment 3 Borja Tarraso 2020-07-16 15:48:27 UTC
Created ansible tracking bugs for this issue:

Affects: epel-all [bug 1857817]
Affects: fedora-all [bug 1857818]

Comment 9 Borja Tarraso 2020-07-22 11:02:00 UTC
Created ansible tracking bugs for this issue:

Affects: openstack-rdo [bug 1859535]

Comment 10 msiddiqu 2020-08-03 05:05:51 UTC
Upstream Fix:

https://github.com/ansible/ansible/pull/71033

Comment 12 Hardik Vyas 2020-08-13 14:21:29 UTC
Statement:

The version of ansible provided in Red Hat Gluster Storage 3, Red Hat Ceph Storage 2 and 3 does not contain the vulnerable functionality and is not affected by this vulnerability. Additionally, these storage products no longer maintains their own version of ansible and fixes are consumed from core Ansible repository.

Comment 17 Michael Kaplan 2020-09-11 16:16:29 UTC
External References:

https://github.com/ansible/ansible/pull/71033


Note You need to log in before you can comment on or make changes to this bug.