Bug 185781 - ifup clashes with $WINDOW environment variable
Summary: ifup clashes with $WINDOW environment variable
Status: CLOSED DUPLICATE of bug 174336
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-17 22:47 UTC by cody koeninger
Modified: 2014-03-17 02:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-18 14:54:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description cody koeninger 2006-03-17 22:47:50 UTC
Description of problem:

This one's hilarious . . . the ifup scripts (eg.
/etc/sysconfig/network-scripts/ifup-eth ) contain lines like:

ip route replace default ${SRC} ${WINDOW:+window $WINDOW} dev ${REALDEVICE}

And guess what?  GNU screen sets the environment variable $WINDOW to
the number of the current window you're in, so if you're in a non-zero
screen window, the tcp window gets set to a small value, killing network
performance.

Version-Release number of selected component (if applicable):
at least fc 2 and 4

How reproducible:
run screen, add a window (^t c), switch to that window (^t 1).

# netstat -rn

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt
Iface
0.0.0.0         192.168.38.1    0.0.0.0         UG        0 0          0

# ifup bond0:9

# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt
Iface
0.0.0.0         192.168.38.1    0.0.0.0         UG        0 1          0


lo and behold, the tcp window is jacked.  Here's why:
# echo $WINDOW
1  (or whatever the number of your GNU screen window is)


Expected results:

the network scripts should rely on something as likely to cause name clashes as
$WINDOW


Additional info:

Comment 1 Miloslav Trmač 2006-03-18 14:54:37 UTC
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 174336 ***


Note You need to log in before you can comment on or make changes to this bug.